Cannot update signatures

CIS Version 10 on Windows 10 version 1511

I am able to download signatures but then the install hangs at 90% (31% on the top)

Go to the CIS installation directory and open the scanners folder and delete the b00xxxxx.cav files if exist and try an update again.

It took several tries but finally worked. I had about 5 b00 files that I deleted. On the first try it got to 90% and hung again. I noted an alert came up unrelated to the install from the firewall and this hung CIS. Had to reboot. After reboot had another b00 file but this time couldn’t delete it, file was in use. Tried shutting down CIS, file still in use. Rebooted to a command prompt and was able to delete the file. Then rebooted to an administrator ID, disabled the firewall and then did the update. It took a while but finally succeeded. After installing the signatures it also updated CIS. I turned off the screen and went to bed while it did that. In the morning everything succeeded but needed a restart (windows also updated overnight).

Hope all signature updates aren’t this bad.

Thanks for your help

:slight_smile: Thanks. This helped me when I kept getting similar errors this morning - CIS 10.x “downloaded” updates to the virus sigs, but failed to install them… and the log was useless to determine why.

Found my “scanners” folder in C:\Program Files\COMODO\Comodo Internet Security, went in and deleted the latest b*.cav, then ran the update again. It downloaded in full, installed, and I was done.

in my case, all files located in
C:\ProgramData\Comodo\Cis\wpTemp\cavsedb
After deleting, everything works fine.

I have tried all the above solutions, but none worked for me.
Is there anything else I should try?

Go to services.msc and ensure the following service is running and set as “Automatic:”

It is running already at automatic.

Run and attach a diagnostic report.

The file of the diagnostic report is 75MB, so I have uploaded at dropbox.

https://www.dropbox.com/s/ujtzh5ro5twq4mm/CisReport_x64_v10.0.1.6258_20170727-073046.zip?dl=0

The diagnostic report looks fine, you did have a cis process crash which then generated a memory dump. But the only other thing I can suggest is to uninstall and install again to see if it fixes the issue. You can follow this guide if you want to make a clean uninstall.

How to fix installation error:

  1. Locate the above mentioned b00xxxx.cav file(s) - mine were in C:\Program Files\COMODO\COMODO Internet Security\scanners

  2. While the updater is NOT running, delete all b00 files.

  3. Run the update utility. If the update fails again, delete any b00 files once more and proceed to step 4.

  4. Install IoBit Unlocker from this link: www.iobit.com/en/iobit-unlocker.php - This is free software that removes restrictions on files. We will use it to delete the b00 file while it is still in use by COMODO. Don’t prevent context menu entries from being installed - you’ll want them. Now, get ready to do steps 5-6 as quickly as you can. Have explorer open to the \scanners directory.

  5. Run the COMODO update utility. Quickly switch to explorer in the \scanners directory and repeatedly click the refresh button at the top by the address bar until you see a new b00 file appear.

  6. Quickly right-click the file and select “IoBit Unlocker” or “Unlock”. When the window opens, click the “unlock” button, then quickly go back to explorer, right-click the file again, and delete it.

The update utility should complete now without encountering an error. If this did not work, you may not have deleted the file quickly enough or your issue may be different than mine.