Cannot Uninstall CIS Completely or Reinstall CIS From Comodo Website

Comodo uninstaller failed to uninstall CIS completely [never happened before] CIS programme has been deleted from my Windows 10 “Programmes & Features” page indicating that CIS has been completely uninstalled. I restarted my PC and attempted to reinstall CIS from the Comodo website as I have done before but this time when the download starts a window opens saying that I need to manually remove my installed version of CIS and restart my PC before I am able to download and install a new version.

I have checked my hard drive and there are still Comodo folders in there. I have tried to manually delete these folders but I get a window open saying, "The action cannot be completed because the folder or a file in it is open in another programme.

Until I can delete these Comodo CIS folders/files out of my hard drive I cannot download another copy from the Comodo website.

My knowledge of PCs is basic so I don’t know what to do next. Do Comodo have an uninstaller that I can use to solve this problem or has anyone on this Forum had the same problem and solved it themselves?

Hi Fastflys,

Please do following steps to uninstall CIS
1.Right click and run as administrator this removal tool after downloading and extracting from zip folder.
2.Choose option to remove CIS.
3.Reboot when it finishes.
4.Run this windows installer tool from Microsoft and check programs and features to see if CIS is listed and choose to uninstall from there.
5.Reboot
6.Try to install CIS using installer available from the here.

Kind Regards,
PremJK

Hi PremJK

Thanks for your response.

When I ran the removal tool and selected Item 02, it went through the motions and at the end stated that all Comodo folders and files had been removed. However, after rebooting the PC, CIS version 10.0.2.6420 [originally on my PC] reappeared and is fully operational as it was before I tried to originally uninstall it earlier today using the usual method which failed and caused the problem I described.

The only difference I have found is that “Comodo” is not listed on my “Add/Remove” programmes page having been originally removed when I attempted to uninstall Comodo CIS earlier today. You suggested that I also run a Windows Installer Tool, reboot and check to see if CIS is now listed on the “Add/Remove” programmes page. Unfortunately it isn’t but this maybe due to the fact that the Windows Installer Tool, listed all of the programmes currently shown on the “Add/Remove” programmes page with the instruction that if “Comodo” was not listed to click on “Not Listed”. The next page then asked me to input a product code and as an example showed a code which was a long string of letters and numbers. I don’t have the CIS product code so couldn’t input it and therefore could go no further.

Would you have a explanation as to what has now occurred and how I could get “Comodo” back on my “Add/Remove” programmes page.

With limited PC knowledge, any help would be most welcome.

Then try running the CIS installer again and choose remove or repair if it gives you the option. Or run the removal tool again and reboot when it finishes, also make sure you use run as administrator on the .bat file.

You can now try the official uninstall tool to see if that fixes your issue.