Cannot turn off network discovery/file sharing in Windows 7


Is that normal, not to be able to turn those off?

Just been looking at my CIS 8.2 firewall. When i click on ‘‘Stealth ports’’ and click ‘‘Block incoming connections…’’, nothing seems to happen, no confirmation etc.

Can someone advise what actions i should take to make my firewall as secure as possible and how to check this is the case?


You can turn those off in the advanced sharing options but if you turn off the windows firewall then they become re-enabled but it doesn’t matter as long as the firewall within CIS is enabled and you have block rules preventing access to those ports used by file sharing then you are protected. You can check the global rules to see what rules are added/changed when you choose block incoming connections from the stealth ports firewall task. I would advise to enable filtering of IPv6 and loopback traffic under firewall advanced settings and enable anti-ARP spoofing as well.


I see my firewall is in Safemode, but under Global rules i have the following ‘‘global rules active’’

I have no idea what these rules are or how they got there (apart from the last one which i added yesterday).

How do i learn what is listed in my rules, and what to list?


These are the default rules that are created when you select block incoming connections from the stealth ports task. These rules allow your computer to receive two important ICMP protocol messages and blocks everything else including stealth/blocking all TCP and UDP ports from being accessed from another computer system. This means that even if you have file sharing enabled, no other computer can access the file sharing ports unless you specifically create an allow rule for those ports. Your global rules as they’re now are perfectly fine and the only time you need to make a change to the global rules is to allow an incoming connection for whatever service or application that you want to give others access too.