cannot submit tickets

tried to submit a ticket via, and was told i needed to register first. the registration for the support forum does provide audio captcha for those who can’t see, that’s why i am able to post here. however, the audio option is not available when i tried to register for the support center. i have some technical issue need to be resolved, but i can’t submit a ticket because i can’t read the captcha and register for the support center…can anyone help with this? thanks.

Hi and welcome endlessintrigue,
Can you tell us what Comodo product this issue is about.
If we can not help with the issue or find another way, I will see if I can get a Staff member to contact you via Personal messaging within the forum.
Kind regards.

Roughly two months ago, I reapplied for the free email certificate, because I thought mine had expired. Turned out my old certificate still had two more months left, so I just discard the link I received in my email.

Now, my certificate is indeed expired, and when I tried to apply again, I got this message:
“A Secure Email Certificate has already been issued for this Email”.

Hi endlessintrigue,
The best I can do is PM a Staff member and point them to this topic.
I hope they get time in the near future to post or Personal message you in regards to this matter.

Edit: Unless another Moderator knows of another way to help in the mean while.
PM sent to Staff.

Sorry for the delay. You should be able to send the email now.