Cannot Stop Device

I recently installed Comodo Firewall and Anti-Virus and now I cannot stop any of my USB devices to remove them. This happens with my USB “thumb” drive and with my iPod.

I’m running Windows XP with all the updates and the above mentioned Comodo products. Also, this only started happening after I installed Comodo programs (I put both on at the same time, so I’m not sure who the culprit is.)

Anytime I try to stop a USB device it gives me that windows message about it being in use by another program at the time. My guess is that is the anti-virus software, but I can’t figure it out and I can’t figure out how to fix the problem.

Does anyone have a solution?

I have a similar problem. Tried excluding E drive from on-access, disabling on-access, disabling HIPS, turning off Boclean (and shutting down BOCore) and even turning off CAVS. Nothing seems to work - I thought it was a problem with my pc but this is only happening since I re-installed CAVS on this computer last week.

:SMLR

Also: I used TrueCrypt, and when I go to dismount a drive, TrueCrypt tells me that it is in use and asks if I want to force the dismount. So this is happening with mounted virtual drives and with usb devices. As far as I can tell, it’s anything that resembles a hard drive (like ipod, virtual drive, usb drive.)

For anyone that knows what they are doing/ is not in a production environment- download sysinternals process explorer.

  1. Open process explorer,

  2. Connect a USB device.

  3. Open ONE UN-IMPORTANT file on your pendrive/USB thing.

  4. Edit the file.

  5. Save the file.

  6. Try to get windows to release the pen drive.

  7. If it does not, do a .dll/hook search in Process Explorer for the file name of the file you edited earlier.

  8. See what process has the .dll/hook open on the file.

Not sure what to look for as I don’t use process explorer much but the parent is svchost.exe(760). It was a word doc I opened so Process WINWORD.EXE.

:SMLR

To add to the list: I connected my digital camera through USB and copied a folder of pics off of it onto my desktop. I was unable to disconnect my digital camera, so I just yanked out the cord. All of my images that I copied to the desktop were stuck on read-only and i wanted to change, edit, or delete them (or the folder) I had to make copies to work from. So I downloaded a program called Unlocker to see what holding up the files/drives. It was Comodo Antivirus - I believe it was the On Access portion, although I don’t know for sure. It had locked all the files. I tried using Unlocker to unlock the files, but Comodo was not having it.

I ended up uninstalling Comodo Antivirus completely and I am now testing out Bit-Defender. Bit-defender has not given me this same problem at this point.

If there is a solution to the issue, I’d love to switch back to Comodo.

Thebradleyroberts: You used a different program but achieved what was needed, just to confirm that Comodo Antivirus is the one that is not releasing/closing the file.

Why does the problem still occur once I have shut down all CAVS processes and then attached my memory stick? If it was on-access causing this surely with it switched off prior to inserting the memory drive then the problem should not occur. Could the actual installation process of CAVS have altered my settings to cause such a problem?

:SMLR

I have the exact same problem. It must be a bug in the driver level of CAVS. Even when I turn off all the features of CAVS, exclude the drive letters from Hips and Activa scan, exit CAVS and then kill all the related processes the USB drives cannot be extracted.

Uninstalled CAVS and the problem was fixed.

Still no solution for that? :-\

And I have the same problem on all computers. Anyone have solution:? ??? ??? ???

No solution yet, still waiting for a CAVS update that will fix this. I suspect we will have to wait for the next beta.

:SMLR

Hi all…

Well most of you have probably figured out how to release your USB drive when CAVS get’s hold of it, but here’s my method that works all the time (even though it’s a pain in the ■■■) (:TNG):

  1. Open My Computer and select the USB drive that won’t release.

  2. On the left hand side (of if you right click the USB drive that you’ve selected), select “Eject This Disk”

  3. Windows Explorer will then give you an error message saying the “Removable Disk is currently in use” and it gives you the choice of 3 buttons… click “Continue”. This same message will appear again, and again click “Continue”.

  4. Windows Explorer will then give you yet another error message saying it “Cannot Unmount Volume”. Click OK.

  5. Finally repeat step 2 and you’ll now find that the USB drive has finally been released.

Hope this works for all of you…

Ed

Hi!! First things first: sorry for my bad english, it’s not my native language (I speak spanish).
I found a trick, but use it at your own risk:
Scenario: Comodo Antivirus & Firewall running on a Windows XP SP2.

  1. Plug in your usb drive. Take note of the letter asigned to it. In my pc, it’s letter "I:"
  2. Go to “Comodo Antivirus”, “Settings” menu
  3. On the left, click “On Acces Scan”, click now on “Advanced”
  4. You’ll find at the right a “Select” button, click on it. It controls what items for exclude from On Access Scan.
  5. You’ll find an empty “Exclusion List”. To add your usb drive, click on “New…”
  6. Type (without quotes) "I:" REMEMBER FIRST STEP: YOU MUST ENTER HERE THE LETTER ASIGNED TO YOUR USB DRIVE!!!
  7. DON’T FORGET TO CHECK OPTION “INCLUDE SUBFOLDERS”.
  8. Finally, click OK, OK, APPLY. Close Comodo Antivirus. Now, try to stop your usb drive. It’s works for me!!

IMPORTANT: If you follow this steps, you have disabled On Access Scan feature for drive I: To be away and safe of virus, you must perform a manual search of virus on usb drive before working with it (a.k.a. “On Demand Scan” feature), because Comodo WILL NOT SCAN IT AUTOMATICALLY!!

If anyone founds something wrong, let me know and correct me. (Sorry for my awful english)

I hope its works for you too.

Sinceresly yours,

Pablo (from Argentina, the land of The End of The World) (:WAV)

Tnx for that Pablo, it seems to work here just fine!

Tnx for your suggestion, too, Ed. Unfortunately it did not produce reliable results for me. :frowning: Hopefully it will work well for others, though!

LM

i’ve tried to put usb drive in the exclution list, didn’t work.any other suggestion?

When is this bug going to be fixed? It disqualififies CAVS for serious use. There is an identical bug in PCTools AV [1]. They can’t say if/when they are going to fix it. Can you?

Is Comodo CAVS using the same code as PCTools AV?

[1]Official Site | Norton™ - Antivirus & Anti-Malware Software

Comodo and CAVS have nothing to do with PCTools as far as I know.

As for this issue being fixed: it has been reported enough times so I suspect the fix will not come until the next beta. This should be out within the next few weeks but will probably not be ready for general release for several months.

:SMLR

As a computer service & repair business owner, I get alot of requests for good security program recommendations. I recently found the Comodo products and feel that they offer a level of protection that is hard to find. I tried all of the applications, and although I want to continue using the Comodo CAVS, I also have experienced the inability to remove USB flash drives etc. As I do alot of flash drive and card reader work, I will also be eagerly awaiting the fixed version. I tried all of the workarounds, but nothing worked on my computer. I have uninstalled Comodo CAVS for now, but will be watching for the version with the bug fixed. Great programs though…worth waiting for!!!

Not even restarting the computer solves the problem?

/LA