Cannot stop CIS since latest build

Windows 7 PC with Comodo
I am unable to stop any part of the CIS.
In the past you could stop all you wanted by right-clicking on the Comodo icon - then set Antivirus or Firewall or… to disabled.
You would get a message that it was disabled for a number of minutes with possibility to change the interval.
Now : You change you check disabled - no message - if you go back it is enabled again.

I also tried taking Comodo out of startup (msconfig) but it started anyway and the strange thing is it is disabled in msconfig (see screenshots)

Whilst it is OK that nobody can tamper with my CIS I myself would like to have some say over it.

I wanted to stop my Comodo because I have a strange issue with my Network center.
When I open the network center the current connection is flashing and I cannot do anything in the Network Center. I can’t even close it. I have to kill it with task manager.

Turn off play sound when an alert is shown under general settings > user interface. Then reboot wait awhile for CIS to load and then try disabling a component. Another issue could be that the alertUI process hasn’t started yet at login when you’re attempting to disable a component so it kinda gets stuck.

Tried all you proposed. Still cannot disable.
What I forgot to tell : this is Pro version.
I also have Comodo on a laptop (Vista) and I checked there:
This is on build (so another build!!!) and it is the free version.
Here I can stop the different components as before.

Another question:
When I installed this Comodo build (clean install because the upgrade that ran automatically gave problems) I saw the option to use Secure Comodo servers. I think I unchecked this. I would like to check.
Where do I find this?

I had other issues so I decided to return to an old image.
I am now back on free CIS 8
Strange thing is that upon start I also got the message “Comodo Security Agent Could not be started” -which is a Comodo 10 issue.
The problem with my network is solved
I am not sure my problems were not caused by Windows Update that I ran a few days ago.
So now I will reïnstall CIS 10pro and see if and which problems return.
Will come back here in a day or 2

So I reïnstalled an old image of my system.
It took me some days to bring my system back as it was.
After all the Windows Updates the last thing I did was uninstall the old Comodo (8) en make a clean install of Comodo 10.

The good news is that both my issues are gone:
I can now stop CIS like before.
My network centre is accessible again.

I did notice however that on installation you cannot opt to not install Comodo Dragon and Geek Buddy.
This is not good!!!