Cannot share files in Home network

Hello boys and girls,

I’ve been a Comodo firewall user for some time now and I love it. I have a desktop computer running Vista home premium 64 bit SP2 and 2 laptops running XP SP3 in my home network. On my destop I have comodo fiewall 3 64 bit installed and on my laptops I have comodo firewall version 3 32 bit. My desktop is connected to my router through an ethernet cable and the 2 laptops using WIFI. I’ve got file sharing setup proprely on all 3 since they can all see each other. Everything seems to be working fine except when I try to access files from my laptops to my desktop and can’t. Then, when I turn my desktops firewall off I can acess my shared files with no problem. I’ve already setup the IPs in the networks trusted zones but it still doesn’t work unless I turn the firewall off. Is there something else I’m not doing or is this a 64 bit issue? Besides that, I use the same configuration on my laptops and they can see each other just fine. Any help would be great!

Yes, you need to make an allow in rule for System and svchost.exe

Thanks for your response futuretech. Just a quick update. The problem seems to be solved. I upgraded to Comodo Firewall 4 on my desktop, used the same settings as I described before on my desktop’s firewall and all seems to work now. The only problem that remains is whenever I use Tunngle VPN on my Vitsa destop machine , I cannot access the shared files on it anymore. Disabling and then re-enabling the local area connection or a reboot seems to fix the problem. Hmmm… I wonder if there is a work around this?