Cannot scan after system restore when disconnected from internet [M477][V6]

[Edited by mod, to help user with language]

A. THE BUG/ISSUE (Varies from issue to issue)

  1. Can U reproduce the problem & if so how reliably?: Yes
    CIS resumes only after the internet to connection and full updated a database

  2. If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. I make AV update happen using General Tasks ~ Update
    b. I have to disconnect from the internet
    c. I use Windows system restore to restore to point in time before the update
    d. After reboot, CIS interface shows ‘At Risk’. See screenshot 1 appended to post 21
    e. I try to scan using General Tasks ~ Scan, it will not scan. See screenshot 2 appended to post 21
    f. I check the database files, they are of size zero
    g. I note that I get alerts on non-signed applications.
    h. I reconnect to the internet, and update the AV database using General Tasks ~ Update
    i. The whole database downloads
    j. I can now scan again, and after scan interface shows green
    k. If I do the same using Acronis to restore, there is no problem

  3. If not obvious what you expected to happen.
    Restore should take the database back to the restore point and leave it functional, allowing offline use. Or it should leave the AV database at the current date.

  4. If a software compatibility problem have U tried the conflict FAQ?:
    n/a. I do not install other program software.

  5. Any software except CIS/OS involved? If so - name, & exact version:
    n/a

  6. Any other information, eg your guess at the cause, how U tried to fix it etc:
    If you restore the system using Acronis True Image with CD (a copy of the system to lies on disk D:) — CIS works without problems.

  7. Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

  8. Screenshot attached.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

  1. Exact CIS version & configuration:
    CIS 6.1.276857.2813, Proactive security

  2. Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All, HIPS=on default, BBlocker=default, Firewall=Block incoming (closed ports) , AV=cloud is on,VK=no,KillSwitch=no.

  3. Have U made any other changes to the default config? (egs here.):
    No

  4. Have U updated (without uninstall) from a CIS 5?:
    No
    a. if so, have U tried a a clean reinstall - if not please do?:

  5. Have U imported a config from a previous version of CIS:
    No
    a. if so, have U tried a standard config - if not please do:

  6. OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, 32bit, UAC= on, admin, VM not used

  7. Other security/s’box software a) currently installed b) installed since OS: a)Malwarebytes free b)

https://forums.comodo.com/install-setup-configuration-help-cis/what-happened-to-the-cis-61-recovery-point-t94553.0.html

When restoring the system ( screenshot)- using the point restoration in Windows.

What is needed is some more information?
If I need to check again
Thank you.
P.S. I checked again. All the same. ( using the point restoration in Windows.)
P.S. Caption – Incoming Outgoing messages (active connections) must be reversed. This interface error.

Is that enough?

[attachment deleted by admin]

Thank you very much for your issue report, which is partially in the standard format

We would very much appreciate it if you would be kind enough to edit your report to put it in the full standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again

Mouse

mouse1 Hi!

I have added to the report.
Is that enough?
Well, I do not know what else to add. (Forum topic is.)

Ta Jenny that’s a helpful bug report, but I just want to check I understand the issue. Can you check my topic subject?

To complete the report we’d like if possible:

  • your CIS diagnostics report, taken when CIS is showing this error. Use the ? in the top right hand corner of the main GUI
  • your complete ‘watch activity’ process list, taken when CIS is showing this error. Use the advanced tasks pane, ‘watch activity’ link.

You can append these in a password protected zip file if you wish. Just say in the topic 'Please PM me for the password"

Best wishes

Mouse

All right. I’ll try.
Since I am now back on the CIS 5.
I can roll back the system to CIS 6.1 the second copy and to try.
I’ll see what I can do. OK?

That’s very kind of you Jenny, much appreciated!

Best wishes

Mouse

mouse1Hi!

Oops.
Now backup on CIS 6.1 Automatically he could not be updated?(5 minutes waiting). Updated a manually. ???
Databases - 16159. I to create a restore point with OS.
Rolling back with OS 3 times.But there is no problem. CIS works well. :-TU
I will to watch and wait for the next database update.

Could it be related to updating the databases? ???
When this was the Problem, the base was 16147.
I nothing to change on my system. What a ideas?

I think I’d try just after a database and restore to just before. If it does not happen then maybe the re-install cured it!

No. Error again. Immediately after the database update.
I’ll fasten the zip

a single database file. Again downloads completely.

I sent the password.

Thanks Jenny, much apprectiated

[at]QA I have the password when you want it

Will forward tomorrow am.

I sent you a password PM.

P.S. I think he does not pick up his base.(As soon as a first update, after the restoration of the system.)
Because the file with the a database actually only that, after upgrading the database
But as soon as he begins to be updated (after downloading), the database is reset to ,b001… .cav 0 kb" and then restored. And CIS starts to working well.

See Reply # 12.

I have the password thanks Jenny.

I process these reports once a day, so I’ll process your tomorrow in the morning

Addition:
Restoring using the OS.

  1. When restoring the system leaves a file with the new database. 1 Screenshot

  2. Not returns the base set point when repairing.

  3. Not only works AV.

  4. Resets the file size with the database to 0 after full download databases (at the time of application databases) . 2 Screenshot

  5. Screenshots attached.

3 Screenshot After the upgrade.

I have edited Reply # 10.
P.S

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

mouse1 Hi

How can I find out.
Will this fix in the next version, or simply be updated in 2813?
I need to use CIS 6.1 but with such a problem - it’s just not possible.
Thank you.

Hi Jenny

Sorry for delayed response.

I’m afraid I’m not a Comodo employee so I don’t know what it’s priority is. We are hoping for a public bug tracker in future.

Just to help could you tell me whether your CIS recovers from this problem if you press ‘update’ in general tasks?

I’m a little unclear from the above whether it does or not.

If not there are ways of resetting updates manually, which I can direct you to.

Best wishes

Mouse

It is updated without any problems, when there is access to the Internet.

But when there is no access to the Internet it such a problem. In principle, you can work if there is an Internet. Must constantly be online after restoring the OS using Windows.
Sometimes there are moments that you want to restore. Since the children are learning. AV can not scan until you update the database.
Thank you .

Just to clarify…

After a restore, and after it has updated over the internet, it should then run for a day or two without internet access, and not go read? Does it do this??

You mean the AV?
Everything works without internet and scans all ok…

This problem only after a restore using the OS Windows.
Am I right to understand you ?