Cannot run batch file

(First attempt at asking a question - hope I’m doing it correctly… :-\ ) Tried searching for a solution but could not find one, so here it is…

Win 10 Pro 21H1, CIS 12.2.2.8012

I frequently use a batch file to rename a group of files. Previously, the cmd window appeared briefly, then disappeared, and a Comodo pop-up allowed me to choose to not contain that batch file again. Second run of batch file - ran successfully, files renamed.

I am no longer getting the pop-up that allows me to create a ‘safe/trusted’ rule for a new batch file so the only way I can run it is to individually tell Comodo the batch file is trusted which means having to navigate to the new batch file every time and tell Comodo to trust it, rather than just run it and say ‘do not block’.

I do not believe I have changed any Comodo setting to cause this - any ideas please?

Thanks, thehod

you may accidentally disabled Comodo notifications from popup “Do not show these alerts” if you wanna enable alerts again go Settings>System>Notifications&Actions then scroll a little down and toggle Comodo one

:P0l

Thanks kyl for quick reply, but no joy. “COMODO Internet Security Pro On: Banners, Sounds” was set; tried off and back on, no change. CMD window flashes up and vanishes, batch file is still not run in a live environment. (poor choice of words perhaps - what I mean is the batch file is prevented from making the filename changes it was meant to make).

Enable / tick “General Settings → User Interface → Show notification messages”.

Thanks CISfan, but it already is (was). Tried de- and re-selecting that, no change. I may have to consider uninstalling and then reinstalling CIS Pro. I’d prefer not to (a) the hassle (b) I don’t know if there is a way to export the current Firewall etc rules I have in place (if not, more hassle to record them manually and then reapply after reinstall).

I’d hope there is an answer, out there somewhere, that might make its way here… :-\

Search for the batch script file in the settings:

  • HIPS rules
  • Automatic containment rules
    If the file exists, delete it
    To export the firewall settings:
  • Comodo interface> General parameters> Configuration> Choose the one activated> Export

Thank you ZorKas

No entry for any batch files in HIPS Rules. HIPS Settings is Enabled, in Training Mode, and Do Not Show Popup Alerts is un-checked.
Auto-Containment showed various ‘ignore’ rules created by my Ignore instruction for previous batch scripts I have used in the past, but not the most recent batch file which started this topic. So, solution still not found… << see EDIT below

Configuration export - very helpful, thank you. One (off-topic, sorry) thought - the General settings > Configuration shows three configs (Internet Security (active), Proactive Security, & Firewall Security). If I export the Active config as advised, will that be the complete config, including Firewall rules?

EDIT : :-[ Realised I had HIPS Settings set in Training Mode which gives no pop-up alerts. The old adage applies - RTFM !! Changed this to Safe Mode - back to normal (phew!) - solution found. RTM also informed me that ‘active config = Firewall Security’ applies when only Comodo Firewall is running/installed, and further reading also revealed when/how Proactive Security would be the current active config. Previous paragraph is therefore also resolved. Thanks to all who tried.

I always used to create my personal config and export it just in case
This allows me to keep the default configs

Of course