Cannot run AutoCad 2010 after installing Comodo Firewall [Merged]

Hi, I had installed comodo firewall on my Xp Sp2 machine. I had Avast antivirus and Superantispyware installed. After i install Comodo firewall, my Autocad 2010 could not run. The program just try to initialize and than show a fatal error. I had tried disabling D+, added acad.exe to trusted application. Uninstalling Comodo resolves the issue, but once it is installed, i cannot run the app. Rest app are running fine.
Btw: when i ran the app for the first time, an event showed up “FNPLicensingService.exe is trying to modify a protected registry key. What would you like to do?” to which i answered YES.

Hi rajeev ,

Welcome to the forum

If you search the forum with “AutoCad” keyword you would find this thread
Please read how guys were helping to investigate the matter, especially the advice given by OmeletGuy re: Buffer Overflow Exclusion rule

Let’s hope that will help

My regards

Hi Rajeev,

Like you I have problems with Autocad 2010 & CIS 4.0.
I have tried the ideas on this thread without success.
The only way I did succeed was to go to Defense+/Sandbox/Run a program in the sandbox and select acad.exe
This was the only way I could run Autocad 2010 without uninstalling CIS 4.0


XP Pro, SP3 32

That’s interestingly odd that sandboxing solves a problem. Usually it is the other way around and taking program out of the sandbox may fix things.

When running AutoCAD unsandboxed what happens? Do you get alerts from AutoCAD? Or is expected functionality broken? I would also like to see a screenshot of the Defense + logs when you try to run AutoCAD unsandboxed. They can be found under Defense + → Common Tasks → View Defense + Events.

Thanks SiberLynx for your reply. I had gone through the thread before posting my problem here. Sorry that i missed on mentioning that. I had tried everything suggested in that thread (including Buffer Overflow Exclusion rule). But the problem persists. Need more help!

Are you using the latest v4 “Firewall only” or you are still with 3.14 ?

That info will be helpful for the developers as well

My regards

Yeah, i am with the latest release i.e v4

rajeev ,
Somehow the new replies to your problem were posted into the tread that I mentioned here above, so you may have a look there again

When trying to run Autocad unsandboxed I get the following message
FATAL ERROR: Unhandled Access Violation Reading 0xb794004 Exception at b2cbe2dh
This occurs as soon as Autocad flags up on screen before the program opens.

Attached is a screenshot of the Defense + logs.

[attachment deleted by admin]

I also encounter same problems. Running through SANDBOX allow the app to run, but not otherwise. I had attached the image files of both the Fatal Error generated by Autocad and Defense+ events.


[attachment deleted by admin]

Usually when AutoCAD 2010 closes like that its because it cant communicate to the FLEXNet service. Maybe something in Comodo is preventing the correct comunication? ??? Just thoughts…

How does the communication with FlexNet work? Does it need an open port for incoming traffic?

how do we find if it needed an open port!


Try adding this folder to the Trusted Files:

C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher

Tried that along with adding acad.exe and flexnet file and proccess to trusted file, application. Turned firewall and defense+ settings to safe mode and disable mode. But nothing works. I think i would have to uninstall CIS. Sad


I’m wondering whether in some of these cases, AutoCAD is being automatically sandboxed. Manual sandboxing replaces auto-sandboxing access restrictions with virtualisation, and virtualisation is working better in the latest release. Turning off Defense+, unless ‘permantently’ does not switch off auto-sandboxing.

AutoCAD may be difficult to un-sandbox. If so the latest FAQ on unsandboxing may help.

Disabling the sandbox turns off auto-sandboxing

Best wishes


I can run Autocad under the following circumstances:

  1. Un-install CIS 4 (or go back to CIS 3 snapshot)
  2. Run program manually in sandbox
  3. Permanently disable Defense +
    I have tried to un-sandbox Autocad but without success.
    I am a fan of Comodo products and will stick with CIS 4, but hope the problems will be resolved.


Does it run if manually sandboxed at the limited level and virtualised. If so that is a strong hint regarding what is going on.


Yes, it runs OK manually sandboxed at the limited level and virtualised.

[attachment deleted by admin]

Sorry lost track of this thread

OK then please try running AutoCAD (main program) out of the sandbox, but declared as ‘installer/updater’ in the computer security policy. Take Autocad out of ‘My Safe Files’ first.

Many thanks