Cannot restore - prompted for password I did not set

I downloaded and installed Comodo backup version 3.0.71266.128. I did a backup of my C drive to an external usb drive. I did a simple copy. 12 hours and 600 GB later it finished without error. When I try to restore a file or folder, it prompts me for a password. I did not set a password. I checked my saved backup settings and they do not indicate that there was a password.

I can use windows explorer to navigate to the folder on the external drive and open the files, so they’re not exactly password protected, but I assume that there is some benefit to using the application to restore from the backup. For exmple, I hope that it would handle file in use issues.

How do I get around this password problem?

Also, during the entire 12 hours of the backup it said 1 hour 45 minutes remaining. And that it was 100%, although 100% of what was not clear, since it was not 100% complete.

This is on 64 bit Windows 7 professional.

It’s great that the backup seemed to work and the price is right, but these glitches make me wonder if there will be some nasty surprises if I ever have to recover from a disaser.


You are asked for password because Comodo BackUp can only restore CBU backup files.
If a file is not recognized as CBU file, it assumes it’s encrypted and that is why you are asked for password.

This will be fixed in next version.


Hi. I just joined so I hope this will go to the right place. I am having the same problem as I see many are. I had a previous version of Comodo and I backed up some files. I went to restore those files and it asks for a password. I never set a password. I read your posts and I downloaded the newest version hoping this would help. Well, it still asks for a password. How can I get around this? I’m not that computer literate so it needs to be a simple fix or I’m out all my data! Thanks

You can use the older version of Comodo BackUp to restore.
You can find each version download link here:

We are interested in determining the cause of the problem.
Was the backup splitted into multiple files? If yes you should try to open the first split. Are them all in the same folder?
We need to analyze the beginning of the backup file (first split).

So please backup the backup file:

  1. In backup step 1 choose “Files & directories” and select the first split of the old backup
  2. In backup step 2 choose a destination
  3. In backup step 3 set split size to 10MB
  4. After new backup is created, please email me just the first split of the newly created backup.



I’ve got the same problem.
Installed the latest version of CBU on Windows Vista.
Backed up to an .iso file.
Reinstalled the machine with W7.
Installed CBU (same version) and am prompted for a password (didn’t set one) when trying to restore.

It can only be a major bug. I can’t open the .iso file with another tool either.

Please guys; I love Comodo software but I need my data back. :frowning:


An ISO file is a CD/DVD image - sort of like a ZIP file but used to create a CD/DVD.

Most burning software alows you to open the ISO file and burn it to CD/DVD.

Once on CD/DVD, the file structure is readable directly by Windows, where you can simply copy any files you need from the backup.

Hoe this helps,
Ewen :slight_smile:

Thanks for the reply but the problem is the following.

CBU gives You the option to create a backup as an .iso file. That worked well. That file cannot now be opened by either CBU or another iso-reader (like poweriso, magiciso,…) as it is somehow password protected by CBU on creation. That’s the whole point.

The reason you are asked for password is that it assumes the file is an encrypted cbu file.
I said earlier that CB can restore only .cbu files, for other types of backup you will have to use third party tools.


Hey Emanuel,

The OP is saying that application that can open ISO files report that the CB generated ISO is password protected and the password can inly have been set by CB.

Ewen :slight_smile:


Alainke2, pleease confirm if this is what you are saying ?
It’s not very clear from your previous statement.
It could be that the ISO image is just corrupted and ISO third party tools might think it’s encrypted.


I am also prompted for a password that I did not set.

o Win 7 65-bit
o Comodo Backup V3.0

Backup settings:
o Backup Source: Disk, Partitions and MBR
o Backup Format: CBU
o Backup Destination: local 1TB removeable hard drive
o Password Protection: Not selected

Restore settings:
o “Snapshot 0” (whatever that means, but it was the only option)
o Verify Image result: “The backup image is corrupted”
– How did this happen? Why is the backup image corrupted? What do I do next?
o Drive letter: Blank – could not get pulldown section to activate
– Is this normal for the “Disk, Partitions and MBR” type of backup I selected?
o Mount backup everytime Windows starts: Selected
– The second time I tried to restore, this option was not available. Does it even apply for my backup type?
o Mount backup as read only: Selected
o Select Items to Restore: Disk 0 (698 GB) → Disk 0 (698 GB) (Default location)
– Comment: Where can I find a mapping from disk numbers to associated drive letters?
o Destination Path: Disk 1 (1.36 TB)

Unrelated(?) issues: 1) The COMODO Backup icons in the Start Menu and Task Bar have been replaced by icons. The text in the proram often overlaps other parts of the user interface. (I see similar behavior with iTunes on this computer with an ATI Radeon HD 3400 video card and a 1900 x 1080 monitor.

Same thing here.
The back-up seemed to work. It did 28 cbu files of 4,29Go.
But now, when I try to restore, it’s asking me for a password I never set…
I am very disapointed.
Obviously, I was using your piece of softq-ware so as NOT to lose my data…
Please let me know what to do…


Please make sure all splits from backup are in the same folder.
How do you know the image is corrupted if you are being asked for password that you claim you didn’t set !?

 You can ignore mount options, these are only when you want to explore content of the backup without restoring.
See Control Panel -> Administrative tools -> Computer management -> Disk management.
     What DPI are you using. Is it default (96) or 120?


Please make sure all cbu files are in the same folder before restoring.


What’s the answer?
Everybody seems to be havinf the same problem.
I am very disapointed.
Please come up with some kind of fix!

We need more information on this issue so please follow these steps here to determine the cause of the problem and a fix for it:

  1. Make sure you have all backup splits in same folder before restoring.

  2. Create a debug file with the instructions here: How to collect debug information - News / Announcements / Feedback - CB - Comodo Forum. You can post here Debug.cbu file or email it to me.

  3. I also need first 64KB of the cbu backup file which is asking for password. We need it for analysis.
    You can use a third party tool to extract this information or use Comodo Backup to backup the cbu file and set split size to 1MB (which is minimum split size). Post here or email me the first split of the newly created backup.