Cannot Remove Network Rules

When attempting to remove an application rule I get the warning: “You need to use “Predefined Firewall Policies” to delete this item.”

Now, this would make sense if the rule I was trying to delete was part of a predefined firewall policy. It’s not, so it doesn’t make sense. The rules are not grayed out, and the corresponding application is being treated as “custom.” And no, I made no predefined policy called “custom.”

If I double click on the rule, I can edit the rule. If I double click on the corresponding application, I can remove rules from within the “Application Network Access Control” child-window. But I cannot remove them from within the Network Security Policy window (as per the incorrect warning).

Were you trying to delete the All Applications rules?

I’ve attached a picture as I’m not sure what you mean. In this example I’m attempting to remove a network rule from azureus.

[attachment deleted by admin]

I tried to reproduce the behaviour but I can’t. Does it happen for every individual rule of an application you want to change?

The exact same thing happened to me. you can delete the entire rule for an app but not the sub rules under it.

if you’re using v4 see here:

Re: COMODO Internet Security 4.0.135239.742 Released

No idea if this is a bug or by design, I hope it’s a bug

I am using the latest version COMODO Internet Security 4.0.135239.742, and have the same error.

Here is my workaround:

  • Create a dummy application rule, i.e for a Notepad.exe
  • Drag the to be deleted rule to this application rule
  • Delete the this application node, it will delete the rule(s) within this subtree

For EricJH, you can simulate it by creating a rule in the section All Applications for instance.

I noticed that deleting a Network Zone will delete all the rules assigned to this zone.

Suggestion for the development team: Would it make sense to have the name or ID of which rule that each line of the Firewall event refers to? The same thing for the log viewer. I have difficulty to figure out which rule had blocked or allowed the event, especially when we have many rules set. Maybe I should create a new thread, but a bit lazy to :smiley:

If you click edit with the application highlighted, it’ll bring up a new window and you should be able to remove rules there.