Cannot reboot to install

[…] Once I initiate the installation process, I get “you must restart your computer before continuing installation” before it does anything else. Restart does not work, of course.

Trying to install: cfw_installer_5732_83
After uninstalling Zone Alarm Free Firewall
Windows 8.1 x64

I split your post from the CTM topic and moved it here.

Try running the Zone Alarm clean up tool to be sure it is properly installed. A link to it can be found here: ESET Knowledgebase .

Can you describe in more detail what your situation is. Did you uninstall ZA and did the mandatory reboot.?What did you do after that?

Sorry for my delay. I hadn’t noticed the split of the topic.

1- I uninstalled Zone Alarm and restarted the PC before attempting to install Comodo.
2- I used the tool you kindly provided above. It did not find any product to uninstall.
3- When I restarted after uninstalling Zone Alarm, I cleaned the registry of any remnants of it. I also made sure there
was no file or folder was left behind.
4- I tried to install Comodo. It unpacked the installer, but immediately after that, it issued the error message.

This is not all. The situation might be a bit more complex than that. THe details follow:

1- Before all of these, I had the latest Comodo installed on my PC under Windows 7.
2- I uninstalled Comodo before upgrading to Windows 8.
3- I upgraded to Windows 8. Then the system did all the rest of the updates wo Windows 8.1.
4- Then I installed Zone Alarm free firewall and used it for a few days. I was dissatisfied and wanted to
revert to Comodo. And you know the rest.

My guess is that something from the previous installation of Comodo under Windows 7 is
holding back the installation of Comodo under Windows 8.1. I think the operating system is
confusing the installer somehow. Could that possibly be the case?

Try running the Geekbuddy removal tool in Safe Mode and see if that helps.

Tank you EricJH for trying to help me fix this issue. I really appreciate your advice.

1- I restarted Windows 8.1 into ‘Safe mode’ and ran the script you advised me to run (note to those who are following this thread: You have to try the Geekbuddy removal tool under Safe mode or it will not run at all)
2- Restarted
3- Ran the Comodo installation package
4- It unpacked the setup files and gave me the same error message

I guess the trick did not work. :frowning:

For problems with Windows installer you can use Windows Installer Clean Up utility. See if it reports CIS traces and let it remove them.

This tool cleans up all Windows installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed.

This tool does not uninstall a program.

Thank you kindly for your wonderful follow up. I deeply appreciate your help.

1- I downloaded and installed the tool you mentioned above (i.e. Windows Installer Clean Up utility)
2- I ran it as administrator
3- I looked through all the entries one by one and there was nothing in there that had anything to do with Comodo

I don’t have any idea what part of the OS is giving the setup application false impression that a restart is needed. Is is a bug in the OS? I used a few trusted registry cleaners to clean up the registry as thoroughly as I could and restarted after each clean-up. I still get the same error. To me, it seems more probable that the OS is doing something funny rather than the setup acting up (or else, this support section of would have been flooded by similar complaints). I am quite frustrated with the OS right now. I don’t think upgrading to Windows 8.1 from Win 7 was the right thing to do.

I see I linked to the old CISremoval tool which works until v5. Apologies for that.

Please download the real Geekbuddy removal tool and run it in Safe Mode.

Then try the latest CIS version which was released the 17th:COMODO Internet Security 7.0.317799.4142 Released!. Try running the installer as admin and see if that makes a difference.

Thank you for your wonderful support. Here is what I did and what happened.

1- Downloaded and ran the Geekbuddy removal tool in Safe mode
2- Restarted the computer
3- Downloaded and ran your recommended copy of the software
4- Result: The same error message. It did not install.

Then I took a different path this time:

5- I ran RegSeeker (I guess any registry editor would do). I searched for the term “comodo” in all registry keys
6- To my surprise, I found tens of registry keys, all related to comodo. I selected them all and deleted them
7- Restarted the PC
8- Ran the recommended version of the software again
9- Result: it worked!

For possible future investigations, I saved the registry keys that I deleted in a backup file. I can share it with anyone who might be interested. Please let me know if that might be of any help to anyone to diagnose what went wrong in the registry that was causing this behavior.

Again, thank you EricJH for your kind support and fantastic follow ups. I really appreciate your efforts.

Congrats with finding this. I will keep in mind to advice to also use a decent registry cleaner in a troubled process.