Cannot print from browsers (IE7 and Firefox)

I have Comodo firewall installed on our home network (three computers, all running WinXp, one of which is a laptop, but not always connected) on a broadband connection.
Apart from not yet being able to see other computers, I cannot get my own computer to print from Internet Explorer or Firefox, even though the printer is connected to my own machine and I can print using Notepad or any of my other applications. If I try to print from the browser, I am told I have to select a printer, and the add printer option comes up, but if I click on it, it says the print spooler service is not running!!!
When I look at the settings for browsers, just about everything is blocked, but not with my applications, which seem mostly to say allow. What’s that all about? I have done nothing to change any of the default settings, and am frustrated. I have a reasonable knowledge of computers from my many years as a user at work and just from what I have picked up, but am not an expert by any means. I am wary of even changing the IP addresses, just in case it all goes pear-shaped and I cannot really be spending so much time on setting this up. Is Comodo personal firewall supposed to be for the average everyday user, or is it really just for professionals or computer experts …? Should I just uninstall and go back to Windows Firewall, where all the computers saw each other on my home network and could see the printer attached to whichever machine it was attached to?

Have you set the policies for your browsers to “Web Browser”?

The only thing I can think of is that your policies for the browsers are too strict.

The thing is, I haven’t set any policies. Everything is essentially as the default setting on installation. All I did was (I may be misremembering!) tell it to treat IE and Firefox as Web Browsers*.

I am running with the firewall set to Proactive security and Safe mode.

I go to Predefined Firewall Policies, Click Edit on Web Browser and it shows

Allow access to:
Loopback zone (whatever that is)
Outgoing HTTP requests
Outgoing FTP requests
Outgoing FTP-PASV requests
Outgoing DNS requests

Block and log all unmatching requests

I haven’t added IE or Firefox to “My own safe files”

Defense events seem mainly to concern IE (which I use more than Firefox for no other reason than I just do) and there were 917 events when I looked recently

When I go into Computer Security Policy and look at the applications that are listed and then I select IE or Firefox, chose Edit and they seem to show everything blocked except “Ask” to “Run an Executable” . The Protection Settings are NO to Interprocess Memory Events, Windows/WinEvent hooks, Process Terminators, Windows Messages

all of which means nothing to me but must be the original default settings?

*If it looks from what I have said here that I haven’t told the Firewall to treat IE and Firefox as browsers, where do I do that now, and is that likely to solve my problem of not being able to print from the browsers (they cannot see the printer because they do not see/cannot talk to the “print spooler service” because, the browser tells me, the service “is not running”

or is it still a network thing, even if the printer is attached to my own computer?

… and if I look at “Firewall Events” it shows the application “System” being blocked … Is that right? The firewall is preventing “System” from doing its work …?
Source port 2142
Destination port 139

also port 445 and ports 2137, 2138, 2139, 2140 appear

I read elsewhere that port 139 is used in file and printer sharing …


Solved it!
While looking for options I looked under Miscellaneous → Manage My Configurations and when I paid a bit more attention to the settings, I saw that I had it set to COMODO - Proactive Security, which is what I had chosen when installing the firewall. (I installed only the firewall, not the antivirus part of the package, thinking that that looked like the highest setting for security and that must surely be the best setting for the average home user). This time I noticed that one of the settings was simply (or specifically!) COMODO-Firewall Security and when I looked at the help associated with that, I saw that that was the appropriate setting for just the firewall, selected that, and that solved the problem.
When I went to the other PC on the network and changed that setting, it allowed me to print. I had to run the install new printer wizard, and it obviously tries to look on the network and you are prompted that System is trying to access the internet (i.e., in this case, access the home network). Click Allow, and everything works!
… so, I hope this helps, just in case someone else finds themselves in the same predicament as myself.