Cannot open PPTP tunnel under Comodo Firewall Pro (final)

v3 unable to allow ip(gre) !

I confirm the problem. Version 2.x is ok, but with Version 3 I can’t use PPTP connect (Windows error 619). My (very sad) workaround is:

  • disable Comodo
  • establish pptp connection
  • soon enable Comodo

Too bad …

I manually added 2 rules in Global rules:

  • incoming traffic for 1723 TCP port (any source to any destination)
  • incoming traffic for IP GRE (any source to any destination)

In the log I don’t see anything blocking. I also tried to add a main rule for blocking all incoming traffic and log it, but also in this way the log didn’t reporting any blocking activity about vpn connection tries (for all other traffic log works correctly).

Please, save my VPN :-[

My configuration:
Intel Core 2 6300 1.86Ghz
XP SP2 x32
Comodo x32
Defense+ active (I also tried disabling it, no luck)

Edit: Solution found:
Open Comodo->Firewall->Advanced->Network security policy->Add…->Select->Running processess…->System Idle Process
Now, you should be back to Application Network Access Control window. Select Add…
Action: Allow
Protocol: IP
Direction: Out
Description: GRE Out Allowed
Check, if you want, “Log as a firewall event if this rule is fired”
Source Address: Any (or select what you think is better)
Destination Address: Any (or select what you think is better)
IP Details: Ip Protocolo: GRE

That’s all, you don’t need other rules.

The bug is only about blocked connection log in Firewall Events window: when I tried to connect before creating this rule, I DIDN’T see blocked outgoing requests, so it was hard for me found what was not working with vpn

Operating system Windows XP Pro SP2 x86
As I installed Comodo Firewall Pro I can’t open a tunnel to a VPN server. As the log shows a PPTP connection can be established (process- System, TCP out remote port 1723), but the GRE protocol is being blocked without any reason (for the process “System Idle Process”) in both directions.
First I thought it should work as the 2.4 version of Comodo Firewall and have created a global rule for GRE protocol (allow, in/out, IP type GRE, source- my local IP, destination- IP of the VPN server)
Then: I selected the “System Idle Process” as an application in “running processes” and created the same rule for it.
Then: allowed GRE for any source/destination in global rules and for “System Idle Process”.
Then: allowed everything for “System Idle Process”.
Then: allowed EVERYTHING in global rules. In this case I saw as the firewall allowed even the netbios broadcasts (UDP in destination/source ports 137-138), which are being also logged as an activity of the “System Idle Process”, but the GRE protocol is being blocked.
What else can I do to allow GRE?!