Cannot obtain ip address on wireless router


When I first install the firewall on my laptop (Dell Inspiron 6400), everything seems to work fine. However, after about two days of on and off use, my laptop cannot recieve an ip address from my linksys router.

The connection strength is ‘excellent’, but the ip is either the 169.xx.xx.xx or

If I shut the firewall down, I get an ip address immediately, and things go fine.

Any thoughts or help would be greatly appreciated.



Check this,3752.0.html

Hello Pandlouk.

THanks for the information. Unfortunately, this laptop is used in a variety of locations, on different wireless networks, which is why I wanted a software firewall in the first place.

So, setting a static ip address will not work for me.

As this problem seems to be caused by the firewall, I was hoping that there was a setting in the firewall that I could adjust to correct the problem.



I take it for granted that you have created a trusted zone?
If not, try that first. Go to Security/Tasks and start the wizard “define a new trusted network”.
When you are finished, restart the firewall.

If it doesn’t help, or if you already have done this,
then you can try to allow all ICMP to see if it works.
Open firewall and go to Security/Network monitor.
Right click on the second rule (your zone rules), and add, add after.
It would look like this.

Action : Allow & log (so you can check in the log what ICMP protocols that are used)
Protocol : ICMP
Direction : In/Out
Source IP : Any
Destination IP : Any
ICMP Details : All

Restart firewall!

Then you can check the log if and what gets through/stopped and make new rules for that.
There are a few other things you can try, but try these suggestions first.