Cannot mount backup or use as a base

I performed an incremental partition backup (although this first backup was a full backup) to a network drive with AES 128-bit encryption. I used the “verify backup after creation” option, and the program stated that everything was successful.

Afterwards, I tried to mount the backup. The program detects the snapshot and partition image inside the CBU file, but when I click on the “mount selected” button, the program states (without asking for a password):

An error occurred while mounting the selected backup.

Then I decided to try an incremental backup based on the first full backup. When doing this with the same AES 128-bit encryption and password, the program started to do a full backup instead of an incremental backup, stating:

Cannot find a backup base. Defaulting to full backup.

Strangely, when I disabled all encryption and tried to base a new incremental backup on the first full (encrypted) backup, the program appeared to successfully perform an incremental backup. However, I receive the same error when attempting to mount the incremental backup file as I did with the first full backup file.

Here is the relevant text I could find in the debug log:

[20.02.2014 19:11:38:765|Th000003b8|LN003469|__internReadRawBufferFromCBUFile] Can't decrypt because 1 [20.02.2014 19:11:38:781|Th000003b8|LN003469|__internReadRawBufferFromCBUFile] Can't decrypt because 1 [20.02.2014 19:11:38:781|Th000003b8|LN020925|OpenExistingBackup] Can't initialize encryption engine because 1 [20.02.2014 19:11:38:796|Th000003b8|LN000521|_BACKUP_RESTORE::SetInitializationInformation] Opening \\REMOTE\xpbackup\comodo\backup1.cbu error 1 [20.02.2014 19:11:38:828|Th000003b8|LN008452|FillAndMarkTreeWithLastIncrementalInfoTH] SetInitializationInformation call failed with API_STATUS 1.

Do you have any idea what went wrong? Perhaps there is something wrong with the encryption.

Operating System: Windows XP SP3 (32-bit)
Comodo Backup version: