Cannot load page from device on home network

I have a music server in my house connected to my home network that I can control using a browser interface. I simply type this in my browser and it opens up the control page installed in the device http://musicserver/index.html. This has worked for me for many years.

I recently started using comodo DNS and now I cannot access the device, it redirects me to this page

http://securedns.comodo.com/main?InterceptSource=0&ClientLocation=xx&ParticipantID=xd34nu3b7tg9r2jcd9fb8jjdzztv2dxl&FailureMode=1&SearchQuery=&FailedURI=http%3A%2F%2Fmusicserver%2Findex.html&AddInType=4&Version=2.1.8-1.67base&Referer=&Implementation=0

I searched the forums and the closest thing I could find on this topic was this, but it was not clear to me that this is the same problem since this web page is on my home network (intranet?).

https://forums.comodo.com/secure-dns-help-cis/manually-disable-secure-dns-for-single-site-t63743.0.html

Anyway, I edited ‘hosts’ in C:\Windows\System32\Drivers\etc as suggested in the topic and put in http://musicserver/index.htm and the page still does not load. I closed and restarted firefox to see if that made a difference and it did not seem to matter. I also put in 192.168.1.102 (local ip address) into the host file to see if that would help and that did not work.

Do you have any suggestions on how to get this to work. I did go and manually disable comodo DNS as outlined in a help page and the server page loaded fine just like it used to do. When I set the settings back to using comodo and tried loading the page, it was redirected as before.

thanks

You changed the Hosts file. To see the effect of the change you need to flush the local DNS cache to make sure the cache is not used and the changed Hosts file will be used.

Does that help when using Comodo Secure DNS servers?