Cannot install CIS Win7 (32bit)

I was using CIS v.6.Yesterday I had a notification icon that virus database had to be updated.I went to do it manually but it never shoed that it connected to the server.It stack to 0%.After trying many times to do it,I decided to reinstalled it in case there was something wrong with the previous installation.There was a problem with uniostalling it and then used the removal tool.Everything went OK.I rebooted,downloaded the latest version (free) and tried to installed it…still trying!!!I always get the message Activating licence,please wait…and remains at 3%.Then nothing happens.I tried so many times that I am too tired to go on with it.This is my last hope and comodo’s last chance to be installed.If not I will find another software!I do not have any more time to spend installing/uninstalling!I hope that this has happened to someone else too and there is a solution.

I installed a previous version 5.9.I found out that the updater system of CIS does not work here too.It tries to update the database but never starts.So it might not be a problem of v6 that stacks on 3% as it tries to connect to internet but it cannot.Any solution?

To rule out the possibility of corruption, or interference from leftover files, please follow the advice I give in this topic:

to fully reinstall CIS.

Let me know if that is able to solve the problem. If not we will continue from there.

Thank you.

I ve done all these but still no luck.There is a problem connecting to comodo servers.As v.6.3 stops at 3% (while contacting comodo to activate the license) I reinstalled v 5.9 (at least I can have a bit of security).I tried to update the virus def. of 5.9 but again cannot connect to Comodo.So if I can make 5.9 to update then I guess I could install v 6.3.So,the big question is…why it cannot connect.Is there the possibility that some windows services do not function as they should do? Does comodo depend on java or netframework or something else and they do not function ok?

Something is up with your system when the installer of 6.3 is not working and installed 5.9 cannot update the AV database.

Does 5.9 run ok other than not updating the AV database? Can you run Diagnostics and see if it reports anything?

Do you have services disabled in your Windows installation as recommended by Black Viper or other parties? If so start with reverting them. Then to see if your Windows properly functioning run the following command from the command prompt:

sfc /scannow

Keep us posted.

Good evening.Some good updated news…after reinstalling java and .net,trying many different microsoft network fixes,doing all these you proposed…and I do not remember what else…when trying to update I saw a line in the gui mentioning that settings from IE will be used.So I opened IE11 reset all settings and retried…nothing happened.I reopened IE11 and tried to access google search…nothing happened.So it was clear that IE had a problem.I downgraded to IE10,I managed to access via IE,installed CIS 6.3 and installation went fine.Just now I am updating the virus database.Maybe CIS should not be so much IE depended.
Thanks you your suggestions.

Glad to hear you got it fixed.

CIS 6.x does not depend on IE. It does not use IE proxy settings when using a proxy. In v5.x there is an option to copy IE proxy settings when connecting through a proxy. May be one of the dll files belonging to IE 11 was not playing nice with networking on your system.