Cannot get Remote Desktop to work.. arghh!! [SOLVED]

Hi Guys,

I’m usually pretty good with all the computer stuff and figure out things alone or with searching the internet for help, but so far nothing has helped me to get my remote desktop connection working with the comodo firewall running…

My Setup:

I got one Desktop-PC and one Laptop. I’m trying to connect to the PC with RDP from the laptop but when the firewall runs it always times out and doesnt even ask me for a password or smth. So clearly its blocked.

When I set Comodo Firewall to off then it works.

I’m running the latest version of comodo (5.9 or so).

I added all kinds of rules already:

  • Global rule to allow tcp connection IN from local area network on port 3389 (thats the rdp port) - didnt help.

  • Application specific rule for svchost.exe for tcp connection IN on local area network on port 3389 - didnt help either.

I turned off all the predefined blocking rules, set my lan to trusted (allowing all connections from the local area network… well this is was already set anyway)

I just can’t get it to work. The funny thing is that I don’t see anything about this in the “logs” (the event viewer thing… is there a “real” log file anywhere?) … not once did it show my connection attemps.

Whats even more weird is that if I turn off the firewall and connect to the PC with RDP, then this connection does not appear in active connections in comodo either…?!?

I mean I’m checkin the log from laptop clearly beeing connected to the PC and it doesnt show up in the active connections?

I’ve been using avira premium before, and so far comodo is alright… I’ve been using it way back… but this problem is really annoying me so much.

Please, I need some help to get it working… any ideas?

Weird… after restarting the PC it suddenly worked…

Only rules that are set at the moment are:

-allow all incoming and outcoming from local network (“at home”)
-svchost.exe is “trusted application” allowing all traffic

I would not recommend to give svchost.exe the allow all (Trusted Application) rule.

Make an application rule based on Outgoing Only and add this on the top:
Action: Allow
Protocol: TCP
Direction: In
Desciption: RDP incoming traffic

Source Address: ANY (or more specific if you like)
Destination Address: ANY (or more specific if you like)
Source Port: Any
Detination Port: 3389

The rule will look like in the image.

[attachment deleted by admin]