Cannot get 2 apps to work with Comodo running

Hello guys,

I cannot for the life of me seem to get the apps Steam and Joost to work while Comodo is running, If I uninstall CPF they work fine, but I would like to keep CPF around,

I am running COMODO Firewall Professional 3.0.14.276 (just updated today, the apps would not work under the previous version either).

I have added both as trusted apps but they still don’t wanna connect, so any help is greatly appreciated.

Hello, Deadman36g.
Can they connect when CFP is disabled?
Can they connect if you set both as trusted apps and remove all entries in global rules section?

  1. No, but they will connect if CFP is completely uninstalled
  2. No, I had one rules under global and removed it, and added both as Trusted Apps but still they are still not connecting

Ok, I have only one thing in mind now that can be checked (just in case):
Defense+ ->advanced->defense+ settings->deactivate D+ permanently
Then restart your computer and try to connect with those settings:

Sorry, I shoud have mentioned D+ is not activated on my machine. Do you have this apps?, and if so do you connect for you?

No I don’t.

I have no idea at the moment what is the reason. Sorry, I can’t help you in this case. Hope someone else here can.

EDIT:
Try to adjust Steam’s and Joost’s settings for them to work well with firewall.

I just googled them two apps, the problem you are having would appear them two apps establishing connections behind CFP 3, in firewall/common tasks/view firewall events, you should see what is getting blocked when you launch Steam and Joost, and then do a screenshot of it and where it says your ip just mask it and write my ip so that your ip remains private, then attach it to your post and someone then can see what port/s or IP is getting blocked that joost and Steam are trying to connect to.

once you’ve done that there are quite a few guys on here who can tell you exactly what custom policy to make for steam and joost in the firewall/advanced/Network Security Policy to allow them two programs to connect and work without anymore problems

Sorry to go off topic but is this really necessary if you’re behind a router? They appear generic. 192.168.1.xxx

ok that steam link is annoying as hell (:AGY) it keeps opening up in this window instead makin of a new one i select making me have to retype eachtime ugh!!! (:AGY). so i used a different browser for it lol back on topic now V

don’t know what your asking :-
but from his post he said Steam and joost works without comodo firewall,
so I assumed that it must be CFP 3 blocking a connection or port that them two programs requires when he runs them.

I googled Steam and Joost and it would seem thats the case since it says this for Steam

Welcome to Steam
Delivers a range of games straight to a computer’s desktop. Includes automatic updates, lists of games and prices, posters, plus access to a large gaming …

and for joost this is what it says it is

Joost - Free online TV - Comedy, cartoons, sports, music and more …
The new way of watching free, full-screen, high-quality TV. All the things you love about TV, fused with all the fun and interactive power of the internet.
www.joost.com/

so for him it would seem that he needs to find out what port most likely in Steam and Joost is getting blocked and then make a custom policy for both of them in Network Security Policy.

if your asking how this would pertain for someone with a router? well I’m not sure if someone was having the same issue with a router invovled and the router was blocking a direct connection to a specific port then they would have to either use port forwarding or if its not as straight forward as that and that won’t work then they can turn on upnp in the router and winxp if Steam and Joost both support upnp.

ok i think i figured out what you asked now lol. umm i don’t know i guess if someone has a router they don’t have to concern themselves about masking their ip like scribbling it out when they post a scrrshot image, but if he hasn’t got a router then its best he scibbles his IP out in the screenshot and atleast then writes over it that its his ip, atleast his IP would reamain private to him and not for anyone to see

Ok guys, I took a screenshot, btw I am not behind a router.

Please note I started Joost and Steam at 6.15 PM

http://img.photobucket.com/albums/v119/deadman36g/Clipboard02.jpg

I had steam running ok with this firewall. It’s not installed now though. :cry:

Deadman36g, let’s try one more thing.
Add one global rule and place it at the top of the list: block/icmp/in/any/any/echo request.
Set Steam and Joost as outgoing only.
Add windows operating system to your application rules (add->select->running proccesses) and apply these rules in same order:
allow/tcp&udp/in/any/any/any/any
block and log/ip/in&out/any/any/any

Nope, they still do not connect.

EDIT:

Try to adjust Steam and Joost to work with firewall through their config dialogs.
Set only one global rule: block/icmp/in/any/any/echo request
Set Steam and Joost as trusted apps once more
Make sure there is no entry for windows operating system in network security policy.

What does the firewall’s log show in this case?

No luck with the config dialogs or lack thereof,
Still not connecting for me,

Here is a new log
http://img.photobucket.com/albums/v119/deadman36g/Clipboard02-1.jpg

http://img.photobucket.com/albums/v119/deadman36g/Clipboard02-1.jpg

Another attempt:

Delete all rules in network security policy and in computer security policy for Steam and Joost, set firewall and Defense+ to training mode, try to connect. What are results?

Ok, first how do I get to computer security policy and I have defense+ enabled should I still change the setting for it? also do you want me to keep the global rule I set?

Defense+ ->advanced->computer security policy

Give it a try. You can re-enable it anytime with mouseclick.

Yes, keep it (just in case: block/icmp/in/any/any/echo request). It’s a very good rule. It doesn’t not conflict with any other rules, but protects you from port scanning-ping-traceroute activities.

Ok, I meant to type I have Defense+ set to inactive (I changed it to training, but it still says Inactive),
I deleted the rules for network security policy and there were no rules for steam or joost under omputer security policy.

I get a popup saying the firewall is learing for joost but it still dosen’t connect and I don’g get a popup for steam and still no connection for it either.

I think there is nothing to do with CFP settings after all those variants we checked. I can’t help you in this case, sorry.