Cannot connect to the Internet unless I disable application monitor?

Hi,

I can never seem to connect to the Internet with the firewall up. It always fails at the ‘acquiring network address’ stage, and I lack an IP address. If I drop my firewall, connect, and then bring my firewall back up to normal, I can use the Internet perfectly. I just have to drop it at the beginning and it’s fine.

I think the problem is at the level of the Application Monitor; if I deactivate it, it will let me connect with the firewall up. Obviously, moving the firewall to ‘allow all’ also lets me connect.

I’ve tried giving svchost permission to do whatever it wants, but this hasn’t changed anything. I’ve used both wireless and wired broadband, different providers, in a different building, and the problem applies no matter what Internet I use!

Here are some screenshots which may be helpful to any helpers. I have the free version, by the way.




My log says svchost is being blocked, but I’ve given it permission to do whatever it wants in application monitor - including allowing invisible connection checks and skipping advanced security checks.

I just want to be able to connect to the Internet with the firewall up, rather than having to pull it down, connect, then yank it back up again. I’ve looked in the FAQ, but can’t seem to find much help.

Would love some help, thanks. :d

PS: I don’t have ICS, no routers, just my lonely laptop, no home networks at all like that. Just have normal broadband internet, wired at home. I had no problems with a trial version of Norton firewall out of the box. I’m at a loss how to stop this weird svchost and “application access denied” problem. Argh.

Oh, here’s some more info.


In Application Monitor, please remove the entry for svchost.exe and also the one for system.

Then go to Security/Advanced/Miscellaneous and make sure the 2nd box is checked, for “Do not show alerts for applications certified by Comodo.” OK.

Then go to Security/tasks/Scan for Known applications. Follow the prompts. When it finishes, instead of stopping/restarting the firewall, please reboot the computer.

When it comes back up and you log in to Windows, you should be able to connect to the internet. If you see any alert for svchost.exe, please allow with remember to create the necessary rules.

LM

BTW, the two network monitor rules you have added (in positions ID 0 & 1) are really unnecessary (and somewhat of a security risk, since you’re Allowing unsolicited inbound traffic). I would suggest removing those. The default rule to Allow TCP/UDP Out (currently in position ID 2) will allow the necessary outbound connections for DNS queries to destination port 53, and DHCP lease renewal to destination port 67; for a basic setup like yours, that’s all you should need.

And a BIG warning on the change you’ve made to the bottom Block & Log All rule (currently Allow & Log All in position ID 7). Change that back to Block, please! By setting this rule to Allow, you are removing virtually every protection against hacking your system that the firewall offers - you are disabling any and all inbound protection. I can’t stress that strongly enough!!!