Cannot connect to Internet because IPv4 Connectivity: shows No network access

I have a problem that I know how to get around but not how to fix:
When I start my Windows 7 PC running Comodo CIS (currently v5.0.163652.1142 but this was just the same on v4) and using an Ethernet LAN connection, the Network icon in the system tray says No internet access.
I know from experience that if I open my Local Area Connection Status window the IPv4 Connectivity: indicator will also show No network access.
If, while still in this window, I then click on Properties and disable the COMODO Internet Security Firewall Driver and click OK, I will then get a connection to the internet.
I can then re-enable the COMODO Internet Security Firewall Driver in the Properties window and click OK and, after a delay, the IPv4 Connectivity: which again shows No network access changes back to Internet.
This really is a pain. Every time I turn the PC on or have to restart after installing updates etc, I have to do this to get online.
Any ideas?

its can be that you have to add the Ip address from your router.

Did you upgrade from CIS 4 to CIS 5?


Yes, I did, Valentin, but the problem has always been on here since I installed Comodo (I can’t remember which version that was at that time).

The trouble was that it took me a long time to work out what the problem was and how to get around it.

You see, I was using a wireless connection for quite a while before I moved my router closer to this PC. When this problem arose I just plugged in my wireless USB dongle and used that until I had more time to look at this.

try to reinstall by first uninstalling CIS completely, clean it with CSC (comodo system cleaner which it’s stable and good). Install it once again (when you do install it again then install it without internet connection).

try to see if your router’s firewall isn’t block CIS. do you have software that is related to your router? If it so then add that folder to the firewall (and in D+ if needed).


It worked, Valentin! :slight_smile:

Thank you very much for all your help.


Glad I could help:)

Take care


Hi Valentin

Sorry but it didn’t work after all. Well, it did work but still not every time I log into this machine.

This is so frustrating! My workaround does work most of the time that I can’t connect to the Internet automatically, but it’s still annoying and time consuming when I have to go through those steps simply to connect.

In one of your messages you said, "…do you have software that is related to your router? If it so then add that folder to the firewall (and in D+ if needed). "

To tell you the truth, although I think I know how to add a folder to the firewall, I don’t know what D+ means.



Does No network connection after using Stealth Ports Wizard (DHCP Broken) help you?