Cannot connect computers on Home network

I have one Desktop running XP Pro (32 bit) and one laptop running XP home (32 bit).

When I connect the laptop to the router with a Cat5 cable I can see files on both computers to share and print. However, when I use wireless, I lose connectivity between the computers.

I can still access the internet wirelessly and both computers are running comodo firewall 3.8 and avast antivirus 4.8 and have the same domain name for the home network and folders and printers are allowed to share.

How can I access my home network when the laptop is wirelessly connected to the network?

I ahve already tried the rules in How To - Understanding & Creating Network Control Rules properly
on the closed forum with no luck.

Thanks for any assistance!

Hi mstanfill,

Could you open up your Network Connections window and compare the properties of your wireless vs.Wired connection.
You may just not have the same services installed/enabled on the General Tabs.
If you don’t know how to correct disparities, if they exist, just let us know.


Both the laptop and the desktop are running
Client for MS networks
File & Printer sharing for MS networks
QoS packet scheduler
Internet Protocol

In the General tab of Local/Wireless Network connection properties respectively.

Both also have RPC service provided by Windows Locator for MS Networks and obtain IP and DNS server addresses automatically

When the laptop is wired the properties are the same as wireless, though the IP address is different.

Any other suggestions?
Thanks for your assistance!


Any help is appreciated.

What happens when you disable Avast?

I’m still not able to connect when avast is disabled.

Are both IP-Adresses from the same Subnetmask/could you post both? Are they static/dynamic(DHCP)? Maybe there is a rule only for a part of a subnet?

Both IP addresses are dynamic and part of the same subnet


Laptop: (wireless) and (wired-when using Cat-5 cable to router)

As how much I got it you connect to the Desktop over the router - once connecting to the router over LAN, once over WLAN?
Might there be an (firewall-) option or security mechanism protecting LAN and WLAN from each other or handling them as different (security-)zones?

I still don’t know how to allow my LAN and my WLAN to communicate in Comodo

Even when I change the security setting to disables on both machines, I still cannot connect them.

It might be that ‘Protect the ARP Cache’ in ‘Firewall → Advanced → Attack Detection Settings → Intrusion Detection’ is ticked.
I’ve a similar error when that is ticked in CIS 3.8. I havn’t tested that in CIS 3.9-RC2 (yet).

There is no check box for Intrusion detection in the 3.8 version I am running. It only lists TPC, UDP, and ICMP Flood Traffic rates and Durations.

I would be willing to uninstall and re-install if someone will walk me through setup to get the settings right

Intrusion Detection is a tab in Attack Detection Settings.

I found the intrusion detection tab, but there was no place to “tick” as Thunderbear suggested.

Screenshot of ‘Protect the ARP Cache’

[attachment deleted by admin]

Absent-minded. Thanks :slight_smile:

neither box is ticked in my settings

Can you show us your Global Rules?

This is the Order of my global rules from the top down

Rule D
Allow TPC or UPD In
Source Any
Des Zone (Local Area Network #1)
Source Any
Destination port set HTTP ports

Rule C
Allow IP Out
Source Any
Des Any
IP Any

Rule B
Allow IP In
Source Zone (Local Area Network #1)
Des Any
IP Any

Rule A
Block IP In
Source Any
Des Any
IP Any

I tried to follow the protocol for Rules for How To - Understanding & Creating Network Control Rules properly on the closed forum.