Cannot add predefined group to "protected registry keys" HIPS rule [I15]

Cannot add group “Важные ключи реестра” (“important registry keys” in russian) to hips rule because the group name contains space at the end.
The bug is resolved by editing group name and removing that space.
Comodo firewall 7.0.315459.4132

Perhaps I am misunderstanding, but is it not possible to name the group whatever you want? If that is the case, then this does not seem to be a bug, but instead a limitation of the program.

Does this adequately describe the issue you have experienced?


No problem to rename group, but THIS group was made by Comodo developers (or maybe translators).

Okay, please provide me detailed (numbered) steps by which a user with the Russian translation could follow to replicate this issue. I need to figure out where the best place to report this is.


  1. Open advanced settings. In section “Настройки безопасности/Защита+/Правила HIPS” double click %windir%\explorer.exe
  2. Click radiobutton “Использовать собственный набор правил”
  3. Go to item “Защищенные ключи реестра” and click “Изменить”
  4. Click context menu item “Добавить/Группы реестра/Важные ключи реестра”. It is expected, that group is added, but nothing happens.
  5. Now click context menu item “Изменить”.
  6. In prompt dialog “Для редактирования этого пункта используйте окно группы. Открыть его сейчас?” click “Да”
  7. Double click item “Важные ключи реестра”
  8. Remove space at the end, click “OK” twice.
  9. Repeat step 4, now group is added

Okay, if this group is pre-created, and any attempt to alter it fails because of the extra space (which if I am understanding correctly is the issue) then please edit your first post so that it is in the format provided here.

Let me know when this is complete, or if you have any questions.

Thank you.

Please edit the first post so it is in the format I linked to. Let me know if you have any questions.


PM reminder sent.

Okay, as the first post is still not in the required format I will move this to the Incomplete Issue Reports board.

If you have any questions about how to use the required format please feel free to ask. I am absolutely willing to help.

Thank you.

Can you please check and see if this is fixed with the newest version ( Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are mainly not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments), so I can forward this to the devs and get this problem fixed.

Thank you.