Cannot add memory to predefined scans, if intended CIS should say? [M173] [v6]

When you change settings for the already made scans (Full and Quick) for example, you can’t add memory region for a quick scan as it just reverts back after applying. [Mod edit: and CIS does not warn you of this fact when you try to do it]


  1. What you did: Try and add a region to the default Quick Scan
  2. What actually happened or you actually saw: It would revert back to the default setting.
  3. What you expected to happen or see: To add the memory region to the default Quick Scan
  4. How you tried to fix it & what happened: N/A
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: Yes, did nothing
  6. Details & exact version of any software (except CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Go advance settings- Security Settings- Scans- Edit Quick Scan- Add Region- Memory- Ok. (Then removes the memory region)
  8. Any other information (eg your guess regarding the cause, with reasons): N/A

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): In Attachments.

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: 2 Screenshots in Attachments.
  2. Screenshots illustrating the bug: Screenshot in Attachment.
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: Default- Turned Heuristics to Medium and turn on cloud scanning in Scans.
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: In Attachments.


  1. CIS version, AV database version & configuration: In Attachments
  2. a) Have you updated (without uninstall) from a previous version of CIS: No, this is a fresh install of windows, no AV’s have been installed.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: N/A
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: Default/ Internet Security
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 64bit NO SP1, UAC Off, Admin.
  7. Other security and utility software currently installed: Malwarebytes scanner, (Realtime off)
  8. Other security software previously installed at any time since Windows was last installed: Malwarebytes
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: N/A

[attachment deleted by admin]

JUst to check

On my computer (Win 7)

The description of the Quick scan says it scans memory anyway, but the profile says it doesn’t.

The description of Full scan does not say it scans memory, but the profile says it does.

So in the case of full scan maybe you shouldn’t need to add it.

And there’s a text bug or profile definition bug in the quick scan.


What does yours say in each case?

Best wishes


Your right, the quick scan says it does scan memory, but the memory region isn’t in the settings. Whereas the full scan doesn’t say it scans memory but the region is there.

Can you try again and see if you can add memory to either?

Should be able to add it to the Quck scan, one would think, unless all predefined scans are locked. in which case there should be a user message when you try.

So three bugs maybe…


No matter what you can’t change the regions on the two default scans and it gives no prompts when you try it just reverts after clicking Ok.

I think it’s intended as ‘read-only’ pre-defined scans, it should however give a warning that changing these settings is not possible, or even ‘gray-out’ the edit option on those.

OK, three bugs, one major. Good catches!

Would you like to amend your report? I’ll let you have all three on one as they are so related if you wish.

Else (far better) just copy and paste two additional ones and amend the first 2-3 fields and subject.

Best wishes


So are you saying make separate bug reports? I can’t do it right now its 1AM GMT+10, in the morning and I’m tired hahaha.

Yes I agree, see subject :slight_smile:

  • quick scan says scans memory, but its not visible in profile. Potentially a major bug if it is actually not there.
  • full scan doesn’t say it scans memory but it’s in the profile (minor)
  • you can’t add memory scan to quick scan (intentional), but the GUI deos not tell you (normal severity)

NO stamina, the youth of today. :slight_smile: (Tomorrow’s fine)

Someone should tell QA about the quick scan though, just in case. You or I Ronny?

Best wishes


Wouldn’t memory just be part of the pre-defined set ‘commonly infected areas’ ? I’m not sure this is a bug, except for the fact that CIS should not allow ‘editing’ of these profiles.

Could be but then the following prompt would be misleading tautology “commonly affected ares AND memory”

Also this choice box should say Memory alone

Cannot find answer in help.

So it seems not but who knows? Should certainly be reported just in case


[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

It is fixed and the options have been greyed out so you cannot change them in the 2 default scan options.

Thanks for testing and letting us know.

Thanks, tracker updated.