Cannot activate license due to missing administrative rights?


just installed CPF and the first impression is very well. Only one problem, which is killing my patience (:AGY) : even though that I was able to install the firewall on my laptop and having administrative rights (without them you would never be able to install it anyway), I’m not able to enter the activation key. This is ridiculous.

The error message: “You do not have administrative privileges which are required to activate license. Plase contact your system administrator.”

As I mentioned I have administrative rights. Or is it necessary to be really Administrator for this?

Thanks, Mr. T

One thing you could try is to do a right click on the Comodo Launch Pad icon in the system tray and select PERSONAL FIREWALL - ADJUST SECURITY LEVEL - ALLOW ALL. This effectively disables the firewall. Once it has been disabled, try activating. If it goes through, repeat the above steps, but set the Security Level to “Custom”.

Let us know how this goes.

Ewen :slight_smile:

Hi Ewen,

did as you suggested, but no success so far, the same error message appears as soon as I want to enter the activation code.

I really believe that this problem’s more related to the general rights the user has.

My user here on the laptop is a normal user within a Windows domain, but having local administration rights to be able to install applications and change IP addresses. Usually the local administration rights include everything you would like to do as Administrator, except some major things only the Administrator can do.

Curious is that even though I have the local administration rights, I cannot enter the activation code, as I described above. Maybe there’s some mistake in the routine which checks the user rights?

Regards, T.

Just a shot in the dark here. Hi Mr.T , I had this error once and it was due to getting two emails, both from comodo. The first included the which I mistakenly copied and pasted trying to activate comodo. I in fact had the same exact error.
The second email has the correct number which is longer that the first, it then worked fine. I don’t know if perhaps this is the issue, but check your (what should be) second email from comodo.

Hope this helps,


This is right. The first email contains the order number, which you need to quote if you want to contact Comodo with any problems with the order etc.
The second email contains the activation code. Make sure you are using the email with something like: activation code in the subject line.


Well, I’m pretty sure that I used the activation code. I have now three of them in my mailbox, great that you receive them for free. :slight_smile:

Anyway, I may know what’s the real cause, but still this is untested.
There are three possibiliies:

  • Nr.1 is that CPF makes a call home to Comodo and because at my first attempt to activate I was behind an other firewall.
  • Nr. 2, which I find more realisitc because of the error message, is that I tried to activate it as user, coming from a domain, indeed having local admin rights, but being not a local user though. So, my next attempt will be to try to activate it as a local user with local administrator rights.
  • Nr. 3 is another thing I did not consider so far. I had the network cable unplugged and so no IP address.

I’ll try it the next days and tell you then the result what exactly helped me then. Thanks for the advices so far.

Regards, Mr. T

Hi again, I would like to stress the point to NOT have 2 firewalls running. In technical theory, you are safe without a firewall for approximately 16 minutes. I would disable your OTHER firewall and then activate comodo. Also Nr.2 is plausable. Nr.3 is the biggest whammy. If you don’t have network cable plugged in, indeed you won’t have any connection at all. I feel that these should not be SEPARATE problems but should all be tried together. Good luck, let us know.



CPF is the only firewall at the moment on my laptop, for sure. So, that’s not the problem for me now.

I now can finally approve that a domain user having local administration rights, cannot activate or update the firewall software. It only works for any user in the local administration group. So, now my created local admin user was able to activate it.

Unfortunatly CPF is not able to handle IE logins to an intranet. For instance, I have a intranet site, which gathers the username through IE and passes him to the right final personalized destination. Even though IE is marked as “safe”, this does not work anymore when using the custom level. It only works again, when set it to “Allow all”. Unfortunately I do not see why, I do not get any popup to approve the connection or not. Seems to me that the whole effort to get Comodo installed, was useless. :frowning:

So, I try another one. Sorry folks…

I can confirm that it seems like a domain user having local administrator rights is not able to activate or update the firewall software. I activated using a local user with admin rights.

The activation problem is slightly annoying, but not being able to update is really annoying. That said, I’ll test it out for a month because even though it takes up a wicked amount of memory, it seems to affect system performance very little.



Don’t be fooled by the appearant “Local Admin” rights to your domain account. It can be adjusted by policies set by your domain admin(s). Your locally made user account isn’t affected by domain-wide policy issues, as long as it remains active and havent gotten its local computer rights revoked. But this should be checked on a regular basis as some domain admins don’t like local user accounts on company computers/laptops interfering with their domain-wide security policies.
This is the case for the company I work for and I constantly have to invoke my local useraccount to enforce security I actually trust. I also constantly catcht them trying to disable my local account, so be vigilant.
Man you should’ve heard the excuse the rep. made when I called him up, telling him I cought him with his hands in the cookie-jar (my comp). Oscar material right there… (:CLP)