Cannot access my network printers

I have a hawking print server hooked up to my network and I cannot print to the printers unless I shutdown the firewall. I can ping the server and I can access the server itself with a web browser, but I just cannot print. I tried creating a network rule for it, but still I am unable to print.

I created a rule as follows:

Action: Allow
Protocol: TCP or UDP
Direction: In/Out
Source IP: Any
Destination IP: Single IP: IP address of my print server as in 192.168.0.45
Source Port: Any
Destination Port: A Single Port: 631

I also tried any for the destination port, but it still won’t work. Anyone who has an idea on how to get my printers working? (:SAD)

Have you set up a trusted network? (security/tasks)

Yes, I did and I even specified the exact IP address. I got it to work though. I noticed in another post that they said to move all the network rules to the top. So, I did and now it works. Thanks anyway though. :BNC

Yes CFP reads the rules from the top to the bottom, so you need to put your allow rule above the default block rule.
Good luck.