cannot access internet after uninstall of Comodo Firewall Pro 3.0

After jumping through numerous, rather ridiculous hoops to get CFP3 unistalled from my XP machine (including running the .bat file to clean up the mess left in the registry), i now cannot access the internet at all. I checked the system event viewer and found the following error message…

Failed to load MOF C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\V2.0.50727\CLR.MOF while recovering repository file.

Of course, i cannot reinstall .net because I have no internet connection!! Please help!

As a footnote, this has chewed up DAYS of my time, and this level of mess after an uninstall in really unacceptable. I would urge the developers to get serious about their uninstall QA before subjecting the populace to this kind if rubbish. By the way, the product itself looks pretty good,. but the unistall is atrocious!

you can try to do a winsock fix… there are tools available on the net which can do it for you if you have acces to a internet connected pc (internet cafe?)… but you can also do it manually…

here are two ways:

[1]

"
Doing this with Windows XP and 2000 is a little harder, due to the fact that TCP/IP cannot be removed, and if you delete the keys from the registry they will automatically be recreated, but empty.

First, you need to reset the TCP stack using Netsh. Click Start->Run and type in “netsh int ip reset resetlog.txt”

The default values for the reg keys are the same on all machines, so you can transplant them from a known good machine.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2

Here is an export of the good keys, although I have personally never used them. I take no responsibility if it crashes the system it is used on. (Set a restore point beforehand) Windows generally will not load networking when in safe mode, so boot to safe mode to replace the keys.

You’ll now want to clear out your hosts file. The path to it is: Windows\system32\drivers\etc\Hosts. Simply open it in notepad and delete any entries you find in it. Save it, and you’re done. It may be a good idea to save a backup of it beforehand, but I can’t imagine you needing it.

Once that is done, reboot."

website: http://www.tweaksforgeeks.com/RepairDNS2.html

[2]

"Not my fault if you mess something up!

Windows XP Winsock Repair - Manual Edition

  1. Show Hidden & Operating System Files

  2. Backup Registry

  3. Delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock

  4. Delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2

  5. Restart Computer

  6. Goto Properties of Network Adapter

  7. Click Install, Select Protocol, Click Add, Select Have Disk

  8. Browse to C:/windows/inf/nettcpip.inf Click Open, Click OK

  9. Select Internet Protocol (TCP/IP), Click OK

  10. Exit and Restart Computer"

website: http://joedix.com/tech_help/2006/07/winsock-repair-manual-edition.html

also try uninstall .Netframework and then do the winsock fix… maybe that is better…

you can also renew the reposity folder… so the information in the security centre is correct again…

Yes. If your using XP…

WinSock XP Fix

Run it & Reboot.

Greetings TripleX

Thanks for the prompt reply.

I did option 2, and it didn’t work.

But i didn’t know how to uninstall .NetFramework first, so not sure if that made a difference. Also i don’t know what you mean when you siggest to “renew the repository folder”. I found it under windows/system32/ebem/, but not sure what to do from there. Do you mean just delete it?

Also i see now that the reported system error is no longer occuring. so the process may have made a difference, but i still can’t get on to the internet.

A little more info… i am able to get on to the computer in question using remote desktop over an internal wireless network. Not sure what protocol RDP uses, but if it’s IP then perhaps the stack is working. The problem is that i cannot get onto the internet from either firefox or outlook, and nor can i IP over to the internal router. So it seems like all outbound requests are failing. I turned off the windows firewall to make sure this wasn’t the problem, and indeed it made no difference.

any other suggestions?

OK… just saw the post from 3xist to run winsock XP fix. Thanks for that… will run that and let you know.

just ran the winsock xp tool… which of course wiped out all my IP settings. Reinstated them and… still doesn’t work.

By the way, the machine i am using for these posts is attached to the same internal router, and there is another machine hardwired over ethernet to the same router, both of which are working fine. the problem is definately in the machine where i uninstalled CFP3.

.NETFramework has nothing to do with your internet. Try doing a repair on your Network Adapter.

Thank you Velletech.

Ok then… can ignore the .NetFramework side of things then.

Could not repair the adapter (have never been able to)… it always fails on the first step trying to clear the cache.
So I disabled the adpater and restarted it… no change.
So I deleted it using device manager and rebooted. still no joy.
So i uninstalled windows networking services (internet gateway discovery and control client, and UPnP interface) and reinstalled them… still nada network access.

As mentioned in a previous post, i can successfully access the machine using remote desktop. Also file and print sharing still works. Do these services run over TCP/IP?

In any case, is there any kind of trace or event log facility i can use to get more information on why it isn;t working?

Look in the windows logs and see what errors occurred… right click on my computer and click on manage… the click on logs… sort on date maybe this helps finding a solution better,

Have already been in those logs and there is nothing to report. At least, no errors, and no warnings that have not been happening since the beginning of time.

I am out of ideas and prayin for inspiration.

Do you have a Restore point back to before you uninstalled Comodo? Also your ISP always has free phone support.

No… no restore point backup available.

And, i’m located in Australia. The free ISP support option is like free blood out of a cold stone. But i’ll give it a try.

Is there no such thing as an IP packet trace with XP? Or at least, a packet-level event logger? Any 3rd party gadgets you know of?

contacted the ISP and they confirmed their policy that they only do support up to the access point of their own gear and not down to the desktop. However he did spend a few minutes with me and came up with another lead… we ran a ping from the desktop to the local router and got the following response…

transmit failed: error code 65.

so packets are not even getting out. will go to my other machine and research this monself.

OK… all sorted. The culprit was zonealarm, and the ping error code led me straight to it.

check http://support.microsoft.com/kb/316414

here’s the story… i installed The Shield Deluxe 2008 about a week ago, only to discover it had no firewall. So i grabbed ZoneAlarm, but it kept hanging during the install. Turns out the two products are incompatible. So then I found Comodo and installed that, but by then the damage was done. The aborted ZoneAlarm installation had changed the Internet Connection Sharing (ICS) parameters. When I uninstalled ZoneAlarm just now from the Windows Add/Remove programs feature and rebooted, the internet connection came straight up.

The piece of the puzzle that still doesn’t make sense is that I still had internet access after the aborted ZoneAlarm install (which is how I downloaded Comodo). The reason I uninstalled Comodo in the first place was that I couldn;t get onto the internet, so it would seem that somehow the Comodo installation triggered a remnant from the Zonealarm install. Anyway I’m back online and that’s the juice for me.

As a footnote to those who run into this in the future, you access ping through START, RUN, CMD to get a DOS prompt and type in PING xxx.xxx.x.x. But you need to ping a specific IP address. if you give it a domain name (e.g. www.google.com) it tries to access lookup services and fails on that. As to a good generic IP address, perhaps the folks on this site can make a suggestion.

Thanks for your help.

check all the hardware this includes the UTP cable, and check if the router is not broken… try do a traceroute, type in the command prompt tracrt www.google.com and watch to how far you are getting…

type in the cmd ipconfig/all and watch the ip details… if the ip is something with 169… than windows assigns and makes up it own ip, it means there no connection between your router and the pc and beyond…

if these small tests confirm the things which you already know, maybe malware destroyed your connection… most likely not, but it could be…

you did winsock fix, so the ip settings are ok I guess… I think it is a hardware problem, but I am not sure… or it could be some incompatible software…

ohh you already solved it… yeah Zone alarm destroyed my machine many times… bad rubbish checkpoint software…

but why you where installing a firewall when the old one was not gone completely ??? that vectore service of zone alarm goes deep in to the system like cfp… yep that is a recipe for trouble… BIG trouble I mean… :SMLR