CAn we trust comodo?


I don’t know if this is the right forum, i think this is some kind of bug. a BIG BUG!

I recently reinstalled windows7, and ofcourse, i installed comodo as a firewall…

after a while, I noticed that no program was asking for permission to go to the internet.

So i pressed the “STOPP ALL INTERNET ACTIVITES”, and nothing happend.

Apparently the comodo was not in controll of the computer, and everything was running free in the system…

How can we trust comodo when theese things can happend?

normaly its only a kind of adjustment, if your secure level ist low → “all programs do what they want”, is your level → like paranoide… everthing will ask for your authorization. maybe a little bit annoying but secure. Maybe your firewall is learning your choises.

Ive been using comodo before, and this is something strange new.

If i look in the settings in network in windows, the comodo firewall is not added to the mobile network device, so it seems like it’s bypassing the comodo firewall.

But if this device can do that, what says that other malware can’t?

I also see that the modem goes on-line before the windows is completely loaded…

New: I just saw that comodo asked for permission to allow a software on my local network, so the local network seems to work, but not thru the modem.


Here is 2 snapshots, one of my local network, and one of the internet one, and as you all can see, the comodo is not installed on the internet configuration, and I can’t seem to find it anywhere…

Should not comodo add this automatically?


Local network:

when you want to find out, why comodo doesnt ask, dont ask windows first.

what is your setting for firewall? try custom policy mode. try high settings about each adress, each port, each protokoll. and look in the rules list, if there are rules which could allow something.
if you are not asked then, THEN you should ask, why it doesnt ask. because then it would show a bug.

i dont look where comodo is standing in windows… i look, if comodo is working.

when you mean, that the tray icon of comodo is not there before the connection after boot is made, it might be just the userinterface that is loading late. the drivers should run before that.

Comodo is working great… for the local network, the internet is another story!

As you can see in the pictures above, the internet network interface don’t have comodo’s “internet security firewall driver”

I can’t find any way to add them, and shouldn’t comodo do it by it self?

The problem is that this happend for a couple of days ago, I i don’t know if it was some kind of update from windows, but I think comodo should investigate this.

There is something terrible wrong, if comodo says “all system are on-line and working”, when they aren’t?

I’ve even tried to uninstall comodo, restart, download comodo again, install, restart, and… the same result…

Shouldn’t comodo add itself to all network interfaces?

I also have high security in the settings, so there is no fault in the settings.
I’ve been using comodo for, well, over 2 years now i think… Never ever happens before!

tell us the setting, so it could be reproduced.

everything inside comodo about firewall. and erase old rules (gerneralized definitions maybe), that could give another result.

i never saw comodo on a place like on your pictures…

the pictures is from the settings in the network and sharing center in windows.

I’ve already tested reinstall, change settings from low, to high, but it seems like it don’t monitor that network connection.

I’m using windows 7 x64 btw.

It HAS worked before, that’s why i think it’s some kind of update from microsoft that has disabled it…

i believe you. but the thing is, even if someone could test this with windows7 x64, until he doesnt know your settings, he can not reproduce this thing.

if “stop all traffic” doesnt stop all traffic, that at least would be a big prove for somethings going wrong. can you confirm that?

as i dont use w7, i am out of knowledge in this case from now.

have you disabled the windows firewall?

I had the same issue, it maybe from the update of windows, try uninstall Comodo and install again, no such things on windows XP only windows 7 x64

I have uninstalled, reinstalled, disabled windows firewall, enabled windows firewall… it’s really strange…
Maybe i need to try to install another firewall to see if that one works, or if it’s something wrong with windows.

just a last hope , after installing Comodo try to update Comodo, there is an update after the installation

I actually just tried that, for 10 minutes ago (aprox), and my comodo said that it was the latest.

if it is 4.1.150349.920 then you are :slight_smile:

I think so, Now i uninstalled Comodo and tried other firewalls, they all worked directly.

So my only solution is to use one of them…
pitty, I liked comodo…

Hi Jobe77,

Please drop v4 (you already did that actually) & use the latest v3.14 - (firewall only!) & you will not have all those problems
You will not need any tweaks … many of them will not work anyway…

I am using v 3.14 on win 7 x64 - working perfectly & I’m not going to use anything else at the moment


  1. Outpost - suports x64 - working perfectly
  2. just wait a bit for Online Armor’s x64 full support ( in beta now)


Where can i find that version?, I can only download the 4.1 from the comodo page…

Update #1: I Found it,

In a forum, i hope that will work…
I’ll be in touch…
Update #2: Didn’t work, I installed it, and it seemd to work, and then i pressed the “block all” function, and I can still surf and mail.

I’m actually writing this post with “block all” on…

I Tried Zonealarm before, but it don’t seems to support VPN, så i had to uninstall it!

Obs! - Somehow, is my mobile broadband connecting as soon as i start windows, even before i enter my password and login, (I had to start it from a program before) i don’t know how or why that happen…

Thanks for reply
99.69% :slight_smile: sure it will work :slight_smile: … the calculated percentage are left for the odd stuff: configuration ; system / Software hardware / other security leftovers /… many things should be considered …

…but v3 despite many/many things forgotten in a huge Wish List that should’ve been fixed & enhanced (that will never happen unfortunately :frowning: ) on both platforms still working strong speaking of Firewall only (with Defense+)


Didn’t Work >:(

I’m getting so mad about comodo and windows at the moment!
Have you seen the pictures i posted in previous?

Typing @ the same time

No there is a definite misbehaviour on your system… as I said probably some leftovers (of Comodo or previously installed security)

“Block all” has one little bug only - tested on many systems - you may not get the connection back after the system was in the suspend mode - that is all

No way that you can have any connection with Comodo’s “Block all” in any other circumstances.

Is you Windows native (''not a Firewall") disabled properly?