Can`t get any updates

I just recently installed CIS to my XP sp3, and I just cant get any virus base updates. The program keeps asking me to update the base, but when i try it, it says that i dont have an Internet connection.
I gave it the routing information from IE8, It took it in I guess, but wasn`t any the wiser…

I installed the updater, but it said that it can`t find the CIS ; I drove the check up program. and it said that everything was fine and the CIS was installed right.

I tried to find a similar chase from here, but just didn`t found one.

However, I`m quite happy for the firewall, I tested it at the Shields Up webpage, and it score maximum points.

Now, if only somebody could help me with this updating problem, I would be very grateful.

Hello and welcome to the forum. Could you please give us your version number.

This can be found under More/ About.

I`ve got the version number 4.0.138377.779.

I guess it`s the latest one.

I had Iolo firewall before this, but when I tested it at the Shields Up page, the port number 135 (or was it 139, can`t remember) was wide open.

As I said, now the ports are stealht.

What updater did you install? Was it this one:

How many times have you tried to update the base? I’ve noticed that on some computers it does seem to have trouble with the initial update, but after several tries it will work (usually).

Also, you’re not using dial-up are you? That could make the update difficult.

If you have already tried this and it doesn’t work then you can always uninstall CIS and then reinstall it. You’d be amazed how many problems this can solve.

Sorry that It took some time to get back to this.
Anyways, now the updating works O.K, it just fixed the problem by itself, but then another problem occurred : the Appkication agent is not running.

It´s difficult to uninstall CIS, because its not listed in remove this program list or Revo uninstallers list ?? (I wasnt trying to get rid of it, but to uninstal and instal)

I had the Comodo system cleaner as well, but it´s not a program for average users…

Thanks for your time !

If CIS is not mentioned on your ARP list it seems that somehow your installation has been corrupted. i suggest you download a new copy from Comodo downloads and also a copy of the Comodo clean up tool. Reinstall Comodo over the one you have. This should give you an entry in the ARP list to uninstall. Using Revo Uninstaller at the highest setting uninstall Comodo and all the remnants Revo finds and then reboot. Unpack the Comodo clean up tool and run it. Once that is done you should reboot again and then reinstall Comodo again. Hopefully this time you will have a full install with an entry in your ARP list.

I have just installed 4.0.14 and it won’t update the definitions ???. It gets to 23% and stays there. I am running Win7 32, have Firefox.