Can someone who is using of Comodo

And who’s configured Mirc’s dcc, and its working tell me how to add the dcc ports.

Preferably with snapshots. So, I know where to go and what to enter.

Coz whats already here doesnt work.

I’ve allowed Mirc in Comodo when I’ve run Mirc thru my ISP’s DNS (since thats the only thing Comodo has asked for, and 113 and port 59). This is the only version of Comodo, that DCC hasnt worked with, since I’ve been using it.

All previous versions worked. There’s only 2 entries for Mirc that I’ve allowed.

The strange thing is, I’ve never had to add anything else in Comodo for DCC to work.

When previous versions of Comodo were installed, all I had to do, was add the ports thats I’ve put in Mirc, to XP’s firewall. (even tho its off)

This doesnt work now, for some reason. I’ve tried everything to get DCC to work, it doesnt work.

My ip is getting resolved, I can log into Mirc, and I can receive files via DCC, so thats not the prob either The only prob is, I cant send via DCC.

I cant remember if Comodo is meant to allow access to Mirc for a localhost (well it doesnt ask for localhost anyway, only the DNS for my ISP). I’m on dialup, so I dont want an answer for ADSL or anything for routers. Since I dont have either.

It doesnt work, whether I dialup from this PC (this PC has a modem), or when I go thru the other PC (which has a modem too, via ICS).

Every other program I’ve got installed and that requires access, works fine when I give access to it, with only the ISP’s DNS ip’s. So why doesnt DCC work with my DNS server IP’s too?

Ok, so no one knows how to configure Mirc properly.

Hi Speedy Gonzales.

All I have done in Application Monitor is add two rules:

Allow TCP ANY 113 IN
Allow TCP ANY 6660 - 6669 OUT

This allows me to connect and use DCC…

You also need to make sure these ports are open in Network Monitor.


So, you have to add these to App Monitor, even tho there’s already 2 entries for Mirc here?

OK, I’ll give that a try. Its just funny I didnt have to do this with the previous versions of Comodo, only the latest version.

This allows me to connect and use DCC…

OK, I shall try adding this too. Ta

So, I put Mirc in for the App, what do I put in for the parent? Explorer.exe??

Or change it to learn the parent?

Nup tried both of the above, and also added the ports I’ve put in Mirc under Network rules and in XP’s firewall. Still doesnt work.

Hi Speedy

It would be helpful if you could post some screen shots of your Network and Application Monitor rules, particularly the rules you have for MIRC.


Well the only ones there are the ones you posted here (the 113 and 6660-6669, even tho I have never had to put these in previously).

And the 2 that ask for permission (port 59 for the dcc server - TCP, and my DNS ip port 53, this one lets me log into a server in Mirc). if I delete the 2 mirc entries in App monitor. And run Mirc again.

As stated previously, I can log in, I can receive files, I can do anything/everything else but dcc send.

Take snapshots of what u have, and I’ll follow exactly what you’ve entered then (it) should hopefully work.

(Edit by mod to delete empty spaces)


Have you changed the default Network Monitor rules?

Which ports, if any, have you assigned to DCC, in MIRC

Do you see any entries in the cfp log when you try to send a file with DCC, if so, what does it/they say?


The default network rules for what?

I havent changed any of the default rules, (the 7 default rules are still here).

I added some to it - the DCC ports I’ve put in Mirc (the network monitor), which didnt work.

Well the ports I’ve put in Mirc are: 2075-2080.

DCC server is ticked (port 59, should this be ticked too)?

This is what Comodo pops up with when I run Mirc (if I delete the 2 Mirc entries from the App Monitor), and once I click on connect Comodo asks for access to my ISP’s DNS server, then I allow it access.

Thats what I put in under network monitor in comodo (Is this where its meant to go)??

Nope, no entries under logs when I try to dcc something.