Can not get ver 3 to install properly

I have been using ver 2.4 on my Win2k machine with good results for a while. I just upgraded to XP Pro so decided to upgrade to ver 3 of Comodo firewall. This is when all the issues started.

My machine is a Pentium 4- 3.0 ghz with 1gig of memory and two hard drives set up as a Raid.

I did not uninstall 2.4 first. When I installed ver 3 it said that it would uninstall 2.4, so I just let it do its thing…however, the uninstall did not go well and reported that a file could not be deleted. I may be wrong but I thought it said it was a file in the System32 folder. Since the installation failed, it rolled back. So I reinstalled 2.4 and then uninstalled it through Add/Remove. I even found a post that said where else on the hard drive to look to delete files and where to look in the registry to delete more. Of course none of the legacy entries could be deleted in the registry.

When I tried to install 3.0 again, it gave an error 2 and said it would roll back. This is after I disabled NOD32 and Spyware Doctor. I then tried disabling everything I could in Msconfig and still no go.

I then booted into safe mode with networking and it installed just fine. Or so I thought.

Unfortunately, when I rebooted it showed that I had no internet and Comodo said at the bottom of the screen that the firewall was not working. I tried the diagnostic tool, but it said all was fine.

I looked at similar posts here, but most of the so called fixes have done nothing…assuming I did them correctly.

There was one post that suggested that Comodo is not compatible with dynamic disks…isn’t raid considered a dynamic disk? I find that hard to believe since your earlier version worked just fine with my Raid setup.

Any ideas…and if so, please spell them out in greater detail. Although I am fairly computer savvy…I am the zenith of my knowledge when it comes to configuring your version 3. In other words, I don’t really understand many of the settings and features in ver 3 and what is best or needed. I currently have 2.4 installed and working but would like to get ver 3 running as I am told it is a better firewall than 2.4.

Thanks in advance.

If you have a restore point go back to it. You really need to uninstall 2.4 first completely then install 3.0. What version of 3.0 did you try to install?

I do not use the restore point…but rather make a daily backup image. Since I have been trying since last week, I really don’t want to restore an earlier image and loose all that has been done and save to this point just to get 3 to install. I have completely uninstalled 2.4 and even followed one of the posts instructions on cleaning as much of Comodo out of the computer and registry as possible before trying to install 3. As I said, the only way I could even get 3 to install was to do it through safe mode. It did install…however 3 will not function properly. I have even tried uninstalling 2.4 in safe mode, rebooting and installing 3 in safe mode with the same results.
Is the post I read, correct? Will 3 not work with a Raid setup???

I forgot…I have tried to install

Some info on error 2 HERE

You cannot install Comodo in safe mode nor any other security.

I saw that post and made sure that NOD32 was not loading when I rebooted and tried to install 3…with no luck.
Was the post that I saw that said ver 3 will not work with dynamic drives have anything to do with my problem since I have a Raid setup?