Can not get the firewall running

Hello,

i want to use the comodo firewall, so i installed it,followed the install wizard and restarted.
Then the firewall icon becomes visible in the tray area and, when i hover my mouse over it, it tells it is being initialized - so far so good.
But after about 2 minutes three popup windows appear telling me something like:
“The comodo network monitor is not running. Reinstalling may fix the problem” (I did that - same problem)
There is no warning or error in the event log or any event related to comodo.

I noticed two things:
A. cpf.exe is up and running before cmdagent.exe
In my imagination, cmdagent should be running before cpf.exe ?!
B. I cannot start, stop, pause or resume cmdagent.exe via the services panel
Maybe that is a feature, i am not sure.

I tried a thousand things like killing cmdagent and restart it by hand, i searched the registry for old entries of cmdagent or cpf or comodo, i uninstalled software, for example vmware which comes with network drivers etc …
I think installed the firewall like 10 times - always the same problem :frowning:
I’ve read the forums here, but i couldnt find any solution.
Maybe you guys can help me out :slight_smile:

Some system specs:

Comodo Firewall version: 2.4.18.184
DSL Modem connected to Ethernet card
Windows Server 2003 Enterprise R2 SP1
Logged in as Administrator
AVG antivirus installed, every automatic service is disabled - i only scan on demand
Security related applications which have been removed/disabled after/before:
Zonealarm, outpost and jetico they are all uninstalled thoroughly

You are correct in that cmdagent.exe should be running before cpf.exe. Long before. cmdagent should start during the boot process; cpf won’t start until you log in to Windows to reach the desktop.

Is Windows Server 2003 Enterprise R2 SP1 a 64-Bit OS?

LM

No, it is Windows Server 2003 R2 SP1 32-Bit

I wish cmdagent had commandline parameters like "-debug"or it would write to the event log, but this way there is very few information what could be wrong :-\

The only times (as far as I can remember) that I have seen this type of error, there are two common causes:

  1. 64-bit OS - Obviously this is not your issue
  2. Conflicting security software (usually Kaspersky AV, or remains of previous firewall)

Firewalls (especially ZA) are known to leave bits & pieces behind that are quite difficult to remove. ZA has its own after-the-fact removal tool; I think it’s on their website. There are also some 3rd-party ones; a link to one of those is in this post:
https://forums.comodo.com/index.php/topic,7369.msg53910.html#msg53910

I would suggest using SafeMode (to minimize any potential conflicts) to uninstall CFP (using CFP’s built-in uninstaller, rather than Windows’ Add/Remove applet),
reboot into SafeMode & use available tools to make sure all remnants of previous FWs are gone,
reboot into SafeMode & clean the registry (using a tool like ccleaner or regseeker - be sure to make backups),
Reboot into SafeMode & reinstall CFP.

I know that’s a whole lot of “SafeMode” but it has proven very helpful in these types of situations.

Hope that helps,

LM

Update:

I resolved the issue with cmdagent.exe starting after cpf.exe - DHCP was trying to find an IP for my network card. Cmdagent.exe now starts before Cpf.exe.

But i still get the “The comodo network monitor is not running. Reinstalling may fix the problem”

@Little Mac:

I followed the link and searched for remnants of comodo,zonealarm and jetico in the fielsystem or registry - without result …

Finally …

I removed the firewall in Safe-mode, and reinstalled it in Safe-mode.
That still didnt help me.

But then i installed Windows Server 2003 in a virtual machine (Vmware) and installed Comodo Firewall in there - works like a charm …
I captured the Comodo install and found out there were 2 drivers copied to C:\windows\system32\drivers - inspect.sys and cmdmon.sys.

BUT these two weren’t installed/copied by the actual (as opposed to virtual) install into my real OS ??? :o
So i just manually copied them in there, from my virtual machine et voila - Comodo firewall now up and running :BNC

I am really happy now, this took me days LOL
But still its odd why the drivers havent been copied by the installer on my real OS ?!

That’s not something I can answer with certainty. Since obviously it was a faulty installation, something must have conflicted. It’s also possible that you had an error with the download that corrupted it from the get-go.

I’m glad you got it figured out.

With that in mind, I’ll close the topic and mark it as Resolved. If you need it reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.

LM