Can not boot after installing latest CIS on Windows 10. Loading screen forever

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
I can easily reproduce it. I have a windows restore point. I just install comodo and my system doesn’t boot anymore
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Fresh windows 10 install
2:Installed nvidia 1070 drivers, Focusrite Scarlett 18i8 drivers (usb audio)
3:Installed vcredist_x64, steam, firefox
4. Installed latest CIS, updated definitions and restarted when prompted
One or two sentences explaining what actually happened:
Windows never boots. the loading screen shows and keeps on showing the loading animation forever.
One or two sentences explaining what you expected to happen:
Normal boot
If a software compatibility problem have you tried the advice to make programs work with CIS?:
It’s a fresh Windows 10 + CIS install
Any software except CIS/OS involved? If so - name, & exact version:
It’s a fresh Windows 10 + CIS install
Any other information, eg your guess at the cause, how you tried to fix it etc:
Toggled many bios features: intel rapid start, ahci. I ended by doing a system restore to the restore point just before installing CIS

Exact CIS version & configuration:
CIS 6100_08
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default modules enabled. I have made no changes except for disabling GeekBuddy during install
Have you made any other changes to the default config? (egs here.):
Absolutely none
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Home SP1 - Version 1511(OS Build 10586.633)
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
Whatever comes with windows Home - Windows Defender

I cannot attach any diagnostics files since I cannot boot after installing Comodo.


Anything different if you uninstall “vcredist” ?

No. “vcredist” is Microsoft’s Visual C 2015 sdk and is required by half of every program ever written

It is unclear if you tried uninstalling it from your response. (I’m assuming that you did.)

Perhaps you are using an older installer for your OS version. Did you check release topic in order to get latest installer?

Please check with Comodo Internet Security V10.0.0.6071 Beta thanks.

Would also be useful to know the windows version (run command: winver) to get Windows 10 build number - as fresh installs of build 14393 and later (Aug 2016 update) have changed driver signing support - which could plausibly be blocking the load process completing?

To go further, the past 4 Insider builds, the underlying Windows code has changed considerably, causing issues.
This seems to have been resolved, with the latest Windows build and the latest CIS not causing issues with other drivers.