Can no longer access USB network drive since CIS 6 install

I have a Linksys E4200 V2 router that has a Western /Digital Elements USB drive attached. This has served as me network drive for about a year now. I just noticed today after checking some backup logs, that I am no longer able to access the drive. The date of loss of access is the day that I installed CIS 6. When I go into the Cisco Cloud Connect software, it shows the drive is up and running, showing remaining space, assigned users & passwords, as well as user allowed sharing access to the drive and its folders. However, within Windows 8 Pro, I no longer see the network drive at all.

Is there some setting within CIS’s configuration that would control access to my network drive? If so, is there a particular setting that I need to change to fix this problem.

Thank you for your help on this matter. -SA Jack

Can you show screenshots of the Firewall logs and your Global Rules?

Attached are the Firewall Log and the Global Rules (Proactive).

Earlier I tried to see if CIS was in fact possibly blocking access to my network drive. So I exited CIS on my wife’s laptop that is running Win 7. However, checking Explorer still did not make the network drive visible. Then I reopened CIS, and within a minute, a new network was discovered. I accepted it. Then checked Explorer to see if anything had changed. Sure enough; the network drive was now visible and working fine.

I then went to my desktop and tried to replicate what I did with my wife’s laptop. I closed CIS, then opened Explorer -and no network drive. Then reopened CIS hoping for a new network to be discovered. Nothing happened. So I deleted the current Network Zone, thinking that CIS would immediately rediscover a zone and allow me to approve it. That was about 15-minutes ago, and I still have no defined network zone, and obviously am on the internet. Go figure.

Any thoughts? Thanks. -SA Jack

In an effort to force CIS to define a new network, I restarted my PC, and sure enough, a new network was created. However, the IPV4 subset mask was identical to my prior definition. But when I checked Explorer, my network drive is now present. Can’t explain why, but all is well for now. -SA Jack

[attachment deleted by admin]