Can I disable alerts for outbound traffic [resolved]

Hi everyone, and thank you to the Comodo team for such a great software.

I need to set up Comodo Firewall on my grandmother’s computer for her to browse the internet securely. And it may seem odd to some, but she’s no computer security expert… (i know, i was in shock too when I found out…)

so to make it easier on her, is it possible to simply disable all security popups for all outbound TCP/UDP traffic ?

in other words, is it possible to have no alert show up at all to ask for permission to access the network when the connection is initiated from applications on her computer ?

(because even if an application is trusted, there may be automatic updates which will cause Comodo to ask again…)


Hi poloparis,
I was really shocked when I heard that your grandmother wasn’t a security expert ;D
However, she (and you) can be (almost) easily helped - without losing any of COMODO’s excellent protection.

  1. go to SECURITY / ADVANCED / MICELLANEOUS and uncheck “Enable alerts”
  2. MAKE SURE to set all the necessary rules in the Application AND the Network Monitor or to “define new trusted applications”.
    If a programme is not allowed to connect to the internet and COMODO does not show any alerts, your grannie will end up thinking that her computer’s broken and blame YOU and ME (:WIN) And we don’t want that. Unfortunately it is not an easy task to set the rules so that everything works without forgetting anything.
    It’s probably best to start (from every possible location)/update/let autoupdate … every single programme that might want to connect to the internet (and that you want to connect too) with the notifications turned on, tick “remember”,permit connection. Once you’ve done that you can safely turn off the alerts. If a problem arises, you can always visit your grandmother, enable the alerts, and fix the problem.
    I hope that it’ll work like that (as I’ve never actually tried it) but it should.
    If you encounter further problems, feel free to ask or have a read through the following tutorials:,1125.0.html,6167.0.html
    which are very helpful when it comes to setting up rules.

Hope that helps.
Have a nice day and greetings to your grandma.
grampa ;D

Sorry, I just reread your post and think I got something wrong.
Do you still want alerts for inbound traffic or simply block it for everything you didn’t explicitely allow without being bothered?

Hi Grampa, and thanks a million. Who better to help my Granny than Grampa… (:CLP)

This helped a lot, thanks, i had not noticed the simple checkbox to enable/disable alerts.

But as you say, it may be dangerous, if Comodo blocks a program to access the network, then we have a problem. It may be the result of an automatic update, or a different parent to launch firefox for instance.

i was looking more for a checkbox that would allow me to disable alerts on all outbound traffic, on the basis that whatever happens on her computer is safe and that she initiated it, even if there are changes in application parameters (like parenting or updates).

For traffic that did not initiate from her computer, then if i haven’t setup a trusted application, then i will block it and not have Comodo ask for permission.

But it’s for all outbound traffic. I fear she’s gonna be submerged by too many alerts, and disabling them is dangerous…

any solution for my poor granny ?

Hello again.
how’s your granny? Hope she’s well!
What you could do (but I’m sure you already know this) to at least reduce alerts to the absolute minimum is - default settings as our starting point:

Please do no.1 first (the order of the rest is arbitrary):

  • go to SECURITY / TASKS and “Scan for known applications”
  • go to SECURITY / ADVANCED / MISCELLANEOUS and tick "“do not show alerts for Comodo certified
    apps” (as you already proposed)
  • open EVERY application (that might want to connect to the internet - remember MS Word and alike
    as well, although this should be a CERTIFIED app) from EVERY possible location (desktop, taskbar
    icon, …)
  • tick “remember” and “allow” when prompted by CPF
  • wait for the first “autoupdate” of each prog (check your app’s menus for possibilities to shorten
    autoupdate intervalls) and “allow+remember”
  • update every app manually and “allow+remember”
  • anything I have forgotten

One alternative could be to set up rules for every single app in the Application Monitor (ignore or learn parent) etc. (my opinion: more complicated and much more work)
click every app once, “allow and remember” and the edit the rule in the AM so that every parent is allowed (too complicated and too much work as well)
go to SECURITY / TASKS and “define a new trusted application”

  • set Alert Frequency Level to “very low”
  • maybe “play” a little with the number of alerts displayed at a time and the length of their appearing
    on the screen.
  • put into “Learning Mode” (so that your granny is not being bothered with new components of
    already allowed apps)
  • make sure to have set appropriate Network Control rules (if your granny is not running a home
    network ;D (well, maybe she does), the default rules will do.

Hope that helps a bit more,
at least until someone wiser (and there are a lot of them here - and very nice ones) finds this thread.

Best regards to your gran!

Romance is in the air. :BNC

Well, errr, poloparis’ granny seems a very fine person (:SHY)…

… though she’s probably at least twice my age (I’m quite young for a grampa, you know ;D)

Unfortunately for you, dear user 4, who’s expecting to witness the beginning of a new love, I’m already in love with someTHING else:
;D ;D ;D

Only kidding. (:LGH)

:smiley: :smiley: :smiley: (:LOV) :smiley: :smiley: :smiley:

too bad for the age difference Grampa, but thanks a bunch for the tips, it’s great. I think it’ll make her life much much easier.

and, when you get very very old, maybe she’ll still be around, and then, (:LOV) who knows… :■■■■ we’ll all be cheering with champagne.

Here’s to your granny :■■■■

I’m glad I could be of some help. I’m sure your granny will like her new firewall.