Can file sharing be turned off with Windows firewall disabled? (Vista OS)

I switched to Comodo firewall some time ago because I was unhappy with Windows firewall, but one thing I’ve never been able to do is turn off file sharing in Network And Sharing Center unless I enable Windows firewall which, to avoid conflicts, I don’t want to do. Is there any way I can turn off file sharing without enabling Windows firewall, or is this not possible, or do I need to set rules in Comodo to prevent any file sharing, or is Comodo already doing this?

Any help, suggestions etc would really be appreciated.

There are various ways you could go about this. You could create rules to block the ports used by file sharing. You could disable NetBIOS and SMBs or you could disable a couple of services. If you want to ensure file and printer sharing is off, the you’ll need to consider the last two options. If you’re happy to leave it on but just block it, option one is best.

Let us know what you’d like to do and I can walk you through it.

I’d prefer to have file and printer sharing is turned off, as long as it doesn’t cause too much disruption and reduce functionality.

Anything you do is completely reversible and, if you’re a single PC with no need for shared resources, shouldn’t have an impact on day to day activities.

There are two parts to this.

  1. Disabling NetBIOS
  2. Disabling SMBs

First NetBIOS:

  1. Open Network and Sharing Centre
  2. Select Change Adapter Settings
  3. Right click your network adapter and select properties
  4. Select Internet Protocol Version 4 (TCP/IPv4) and select Properties
  5. Select Advanced
  6. Select WINS
  7. Select Disable NetBIOS over TCP/IP
  8. Select Ok…

Second SMBv1, v2 and v3

  1. Open an elevated command prompt (Administrative command prompt)
  2. Enter the following commands one at time pressing Enter after each.

sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
sc.exe config mrxsmb10 start= disabled
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

To re-enable:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb10 start= auto
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

The alternative to this is to disable and stop the Workstation and Server services vis services.msc. Doing this will also cause the browser service (nothing to do with web browsing) and the Homegroup Listener services to be disabled.

  1. Open Start
  2. In the search box type services.msc
  3. Locate Server (LanmanServer)
  4. Select Stop and Disabled
  5. Repeat for Workstation (LanmanWorkstation)

Restart the PC.

Thanks a lot. Went for the straightforward stopping the 2 services option. I’ll report back if I have any problems :-TU.