Busy Icon every couple seconds - Outlook 2013

In September, when I was setting things up on my brand new lenovo laptop, I installed CIS as I always do and noticed an issue when Outlook was running. I noticed that when I ran Outlook 2013, with CIS installed, a busy icon would appear every 1~2 seconds lasting about the same amount of time. I looked into the task manager that Comodo also develops, and it was showing indexer and search related processes executing and terminating just as frequently as the busy icon.

I uninstalled CIS and the busy icon immediately went away, I did not check on the processes I had noticed executing and terminating frequently. I left things like that until just the other day when I was either hacked or infected with malware. I immediately formatted my disk after backing up some documents. I’ve almost finished setting the laptop up again, and I have CIS installed. I intend to keep it that way, but I need some help.

Why is CIS causing a busy icon to appear when Outlook 2013 is running? How can I bypass the root cause of this. I don’t even mind having a small security hole in my system. I would just like to have things running smoothly and actually have some security, more than Microsoft’s essentials or whatever its called; which was installed when my system was blatantly compromised.

I hope somebody can help me understand why this busy icon is appearing.

Still no idea why any of it is happening, but I’ve found a bit more info on what is happening.

from the Event Viewer Logs

Faulting application name: SearchProtocolHost.exe, version: 7.0.7601.17610, time stamp: 0x4dc0d006
Faulting module name: AppvIsvSubsystems64.dll_unloaded, version:, time stamp: 0x515dec46
Exception code: 0xc0000005
Fault offset: 0x000007feedb33f08
Faulting process id: 0x2ae0
Faulting application start time: 0x01cefbbc1377e750
Faulting application path: C:\Windows\system32\SearchProtocolHost.exe
Faulting module path: AppvIsvSubsystems64.dll
Report Id: 51424379-67af-11e3-aa20-902b6bfee3b3

Each crash has that same information; excluding the striked information.

1.) I’ve tried to fix it using a google search on SearchProtocolHost.exe AppvIsvSubsystems64.dll_unloaded it suggested including the microsoft office 15 directories to my environment variable PATH; I rebooted immediately after my alteration of PATH.
For more info: SearchProtocolHost.exe fails with AppvIsvSubsystems64.dll

2.) I also removed Outlook 2013 from my indexer in control panel.
– Neither thing resolved the issue at the time.

A) When I put my computer into standby mode and resumed this morning however the issue was resolved. I just rebooted and the issue is still resolved, so one of these steps would seem to fix the issue.

B) I would prefer to have the root cause remedied however, as in whatever part of CIS is causing this issue has a fix applied to it. This is because I prefer to have my inbox indexed so that I can search for old mail easier.

I had this problem on before also on my machine with office 2013 on windows 7. For some reason one of the Comodo filters causes the search processes to crash. I never did find out what was causing the crash because it would chew up 90% of the cpu, made it hard to play around with settings so I just added the search processes to AV, HIPS, and behavior block exceptions.

Thanks, I’ll give that a shot