Bugs report for CAVS Beta

Hi All,
Pealse report here the bugs for CAV Beta
Thank you all for your kind support.


So i am back and i am willing to try the new beta. i hope it works much more better. Have it any Speedness Performances in this release?.

The other thing is what i want to say that i will test it on my Real Machine because testing on a virtual PC is not helpfull…because it is not 100 % sure if Comodo Works in the VM good that works in “Real” aslo this is the problem about VM. So i am now willing to try…

Another Question…How does it look with CAV and Translation into other Languages?

I installed the antivirus and restarted the system just like the program asks. Then I log on to my system and the window to search for known applications and then suddenly windows stops loading. Nothing works anymore, I can only move the mouse. Then I hear a beep and then I can’t move the mouse anymore. I’ve had this 3 times in a row. The 4th time I need to restart, because the system freezed, I decided to start the system in safe mode and remove the antivirus again. So I guess there’s still a bug in the antivirus. Hope this can be fixed soon

I have exactly the same Problem. So i cannot test the Beta for now. What make the Things so difficultly in Development??? To push out a Stable release? what is the Problem? In the previous beta CAV was able to start in the New Beta not what ist that?

Okay, I’ve got one bug and two observations.

Bug; Still doesn’t play well with True Launch Bar v4.1.4. Treats each button as if you had requested an on demand scan (right click).

Ob. #1; I’m not too keen on the idea of sending a plain text file of darn near all the files on my system across the internet, especially the ones in C:\Documents and Settings<user>\My Documents etc. as a default option when running CAV after the first boot-up. Yes I know that I can pick and choose the folders and files to scan in the Advanced section, but if a user wasn’t paying attention the folks at Comodo would be looking at some weird stuff coming across the 'net.

Ob. #2; When the mouse pointer is hovering over the beta installer (CAVS_Setup_Beta2.0.9.30.exe) the little yellow balloon pops up and tells me it’s v2.0.9.29. Nit picky ain’t I?

Oh make that 3 observations…

Ob. #3; You guys really need to get a faster server. It took 1 hour, 36 minutes to d/l the file over a 3mbps ADSL line.

Other than that it’s working great!

Blast! I’ve just spent the last couple of hours looking at this issue (based on someone else’s post I thought I was the only CAVS user with this issue). Actually, I’m quite relieved… it’s not just my system… Wooohoo. So, for your confirmation of this issue I’m very grateful Zzyzx.

Ob. #2; When the mouse pointer is hovering over the beta installer (CAVS_Setup_Beta2.0.9.30.exe) the little yellow balloon pops up and tells me it's v2.0.9.29. Nit picky ain't I?
Yes, very. ;D
Ob. #3; You guys really need to get a faster server. It took 1 hour, 36 minutes to d/l the file over a 3mbps ADSL line.
It also took me just over 1.5 hours to download it as well. Mind you, I'm on GPRS.

Hi Messias/josy1982,
Please provide below information to reach to the root of problem on your system.
Did you select "Delete user profiled safelist DB” while uninstalling previous version? Did you get any HIPS alert before syatem hanged? Did you get UPSDBMaker dialog on bootup and have you pressed ‘start’ button? Do you have any other AV installed? Could you pls send/upload the troubleshoot log?


Hi josy1982 ,
Welcome back.
We have tested this release on various system under different payload for long duration. The performance is much better than last release and now system does not seems to slow down when on-access/HIPS is ON.
Translation into other languages will start after product release to users.

Thanks regards

True Launch Bar bug is not yet fixed.

You have choice to deselect the option “Send user profiled Safelisting report to comodo lab” so that the report will not be send to comodo lab.
ok, we will remove all other extension except executable extension while making the safelisting report. This report contains the file name, version and size, etc. information which is not found as safe. This information can be used by comodo lab to collect the files from internet for analysis and addition into safelist database.

The setup released is the latest one but developer missed to change the internal setup file version. Just a typo mistake, nothing to worry about it.

We hope soon server will be able to serve fatser. By the way how much time it took previously for you?

Previous beta installers took less than five minutes to download on my 8 meg broadband. The latest version took 25 minutes.


ouch, this is the second time i’ve lost windows on your update
the last one caused me bsod
and now for the first time i’ve seen the hal.dll issue

i’m on my linux box now

love your software (especially the firewall)
but these is going bad

and the cavse uses more memory than before
the last was 14mb+ x 2
now they’re both 19mb+
on my initial observation
thats before i shut down and lost the windows

thankfully no important files are lost
just got to find another way around it

Hi kishork,

Yes i have compleatly uninstalled the previous Version. I have installed the New Version of CAV after Reboot a POpup Apperas from HIPS He ask me for the services.exe i have checked yes and than the system is totally frezezing an i cannot login.


Hi josy1982,
Could you please upload the services.exe after compressing? In btn, please boot in safemode and go to settings page and disable HIPS application control. Now reboot and check wheather it still hangs.
Also pls save the troubleshoot log and upload cavasm.log.

Thanks & regards

Hi isaac,
We have not yet replicated this issue. What was the another way around you have found to fix?

Thanks & regards


My download wasn’t so slow - i guess it was ready within 10 minutes, i didn’t check - , i’m in Hungary with an ADSL connection (max 1MBit). UPD = User Profile Database (UPSDbMaker, etc).


  1. I’ve uninstalled previous release and deleted virus database and the requested thing :).
    FEATURE REQUEST!!! I met with this already at a cpf beta: you only tell me that the computer reboot is needed BUT you didn’t actually tell me that you WILL REBOOT MY COMPUTER asap. i click on the OK button. This is a veeery annoying thing, ask a confirm at least, thanks!

  2. installed the beta.

  3. reboot.

  4. i logged in with admin user rights.

  5. i’ve learned from my earlier mistakes so i defined what the cavs can search. I was also able to set up some safe-listed directories, but i wonder if this is useful if i also define where the cavs can search ???

  6. sometimes cavs used too much resources but not 99% so i was able to click on the Pause button to do the things i have to. I don’t like that i can’t modify the cpu priority, i wonder if i could do this if i add rights through the service’s registry.

  7. it seems - i’ve seen the directories and the time - it doesn’t matter if i defined my safelist, the engine searched the files there as well :frowning: I really don’t care how much safe files i have there. I thought the option exists to make the search process shorter! (:AGY)

  8. the process displays me a G:\directory\ instead of G:\directory (just an example, but for all drive letters there’s a double slash).

  9. cavs hangs at large files (for around 30-50s with 700MB) but it seems it’ll update the scan time when it finishes the searching process.

331294 checked files
UPS db: 23978
Marked by user (by user?): 18213
Time: 01:54:21
Judgement: the UPD search speed is acceptable, the unnecessery search isn’t.


  • HIPS detected my Hungarian notepad, the Hungarian Internet explorer file, etc.
  • I wonder why the UPD search searched for all files, like my saved CorelDraw ones. Do you think there’s any chance to add them to a list or what? What the purpose of searching these files as well?
  • It’s not easy to log in back to my computer if the HIPS alerts you cause of the screensaver .scr file.

Well, what can I say? This version surpasses my expections, and seems to have fixed all the problems on my system that I reported from

At least it’s working OK for somebody on the forum! It even uploaded my safelist! Amazing. I’ve even been daring and turned HIPS back on.

So first impressions after the first day’s installation are THUMBS UP!!

Rich :wink:


can u help us replicate this hal.dll issue pls!!!
we just can’t replicate the bloody thing!!!


Have you rebooted your computer 2 or 3 times? I thought the same and after the install, the created database i thought everything is fine. But, after i rebooted my computer again cavs freezed my computer after i’ve tried to log in.

I used the same trick like before:

  1. reboot in safe mode
  2. start | run… | services.msc
  3. modify the cavs properties to “disabled”.
  4. reboot
  5. log in
  6. repeat step 2. and modify it to manual, then start it.

On-demand scan time: ~ 19 - 24 files/second with average cpu usage. It’s very interessting that the more files it scans, the better this per value is :THNK

Hi Kishork,
Yes, I selected “delete user profiledsafelist DB”. The previous version was already uninstalled. Another antivirus was installed on my system, but I uninstalled it before I installed the beta. I’ve had a couple of HIPS alerts before the system hanged.

Do you know what are these “arc” and “cavname” files at my temporary directory? From submitter?

Memory scan time: 416/00:02:12