BUGREPORT: Bug with ask rules (V3.0.12 x32)

The ask rules in the firewall are treated as blocked.

I had a confirmation from another italian member of the forum, but it would be nice if someone else tests this too.

thanks,

Panagiotis

Bit confused? How to reproduce this?

Here appears many windows asking for confirmation to enable or not, after permit and maintain selects to remember, the window again appear several several times … and
Tested in two computers and the “learning” not work after turning off the pc and connect again …
An example and the process “nod32krn.exe” will be the Antivirus NOD32 … for this process appears many windows of confirmation, even he already has the rule in the first recorded since pc is restarted after the install of Comodo 3 … after clear that the pc off and re-connect that happens …

The same is true for the Defense+…

The way “learning” that seems to operate after a while and the windows asking for programs that confirmation before he already had “learned” again appear …

(:AGY) (:AGY)

Actually, ASK rule works great here, and worked fine also in Betas;
You can easy check this by using an e-mail client (other than Outlook) – let’s say Thunderbird:
choose “e-mail client” from the predefined FW policies – this automatically creates an ASK rule.
Then, start the app., and choose “check for updates”, for example – FW will nicely ask you…
The ASK rule is great!
Gabi

[attachment deleted by admin]

They work only if you have not another general block rule at the bottom.

Create the following rule (at the bottom) on your email client rule and check again. You will not get any pop-up.

Action = Block (enable Create an alert if this rule is fired)
Protocol = IP
Direction = In/OUT
Description = Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
IP Details = Any

It seems that the block rule take the priority over the ask rule, although it shouldn’t, since it’s the last one.

Panagiotis

You’re right, it does… :o but it shouldn’t; I’m confused…
Anyway, it’s a setting easy to mess with, when you click block -remember.
Gabi