Bug with Website

Dear Support,
Love the browser! Noted with website truthorfiction.com after doing a search and then clicking on link get 403 Forbidden error. Edge browser works fine in this same situation.
Thank You!
Robert

Hi and welcome DoctorA,
I can’t reproduce this issue, the searches and links I have tried on the mentioned site worked.
Try clearing your browsing data and try again.
Ctrl+Shift+Del

If the above fails and it is not to personal, can you post the links you are having issues with?

Thanks.

Thanks much for your prompt reply. Cleared history with same result. Here is link that clicked on after search at www.truthorfiction.com:

https://www.truthorfiction.com/usmc-no-ammo/

Thank You,

Robert

Hi DoctorA,
Sorry that link is working here using both Chromodo 50 and Dragon 52.
Does the issue persist in incognito mode?
Ctrl+Shift+N

Thanks.

That did not make a difference so I looked at any other changes. Noted my Antivirus program Vipre was disabled. I forgot I had disabled to install software. After re-enabling Vipre I am now able to access the website. I do not know why it affected things this way but appears this resolved my problem. Thanks for all the help!
Robert

Edit: spoke too soon. Worked once then same Forbidden 403 error. I will just have to use another browser with this website.
Thanks for your efforts.
Robert