Bug with uninstall

I wanted to try the new CIS 6.

The installer said I have to uninstall CIS 5 before.

However, when I tried to uninstall it, I have a Windows installer error (see the screen capture below).

In order to solve it, I thought I would install CIS 5 over its self in order to repair it. However, the latest installer I have seems to not be the latest version, because it didn’t want to install over my CIS 5.12.256249.2599 and it said I should uninstall my CIS 5 first. So, the same problem again!

Am I condemned to use CIS 5 forever or is there a way to install CIS 6?

[attachment deleted by admin]

Hi pourquoi,
Try running the unofficial Uninstaller Tool for Comodo Products in Windows Safe Mode if possible, before attempting to re-install.

If the above fails run the unofficial tool again and then run the Windows Installer CleanUp Utility using caution only to remove CIS related entries.


Thank you for your answer.

I tried that the unofficial uninstaller, but it didn’t work.

Fortunately, I remembered I had a snapshot from Total Uninstall and thus I was able to remove CIS 5.

But, concerning CIS 6, what a shame! It doesn’t even look like a firewall. There are no settings for anything. So, I will still run CIS 5.