Bug when clicking on browse support forums.

hello developers,
I have a bug on windows 7 64-bit with comodo 5 final when i click on browse support forums,
it opens the opera browser but i never changed my default browser on this OS and it’s always IE.
what’s the key in the registry to change this problem ?
i want to link the good browser with the comodo GUI so when I’ll click on browse support forums, it will open IE normally.
thanks for your help.

PS : i have comodo 5 final installed on xp 32-bit and IE opens normally as opera is installed too.

As far as i remember and concerning xp, is not handled by the registry but directly from
My Computer-Tools-Folder options-File types: check the correct associations for url, http, https.

ok but it’s handled by IE.
now I uninstalled the all opera with revo uninstaller and when i click on browse support forums,
nothing happens anymore.

what should i do now ? uninstall and reinstall comodo 5 ?
I’m going to try that anyway.
there are too many keys in the registry for me to find the problem.

ok now i set google as default browser and comodo forums opens in google.
but when i set back IE as default, it doesnt work anymore.
I’m going to check “associate a file type or protocol with a specific program”…
to see wich file is associated to chrome, maybe i’ll find something…

Associate url, http and https manually to IE.

It works with opera, chrome and firefox,
how to make it work with IE so ?

I just checked with my Win 7 x86 and found out I cannot change the mentioned protocols to IE either. See attached image. Changing a file type to IE is possible.

My gut feeling says this problem is about Windows rather than CIS. But I cannot substantiate that.

[attachment deleted by admin]

Try Start Menu > Default Programs > Set your default programs > Internet Explorer.

Then select to - Set this program as default : for all file types it can open… like OS default.

Or select to - Choose defaults for this program - the window is self explanatory.


I did not mention in the above. IE is not in the list of programs to be set as default. See attached image.

I am wondering what ailef reports here.

[attachment deleted by admin]

in fact it seems that it’s a problem with .shtml
I changed it to open with IE but it didnt work.
maybe i should reboot also.


When i saw first pic, I thought you got there by other means and that was why IE wasn’t shown.

IE is not my default, and i have Firefox, CD, and Chrome.

I suppose the key question for me and possibly OP is, why IE shows on mine and not on yours? His?


Yes probably reboot to let the registry change propagate and get picked up.

must be a problem with IE and windows 7 cause it works fine with XP.

Hello one and all.

Given that this seems like a windows problem, I’ll move it to help, if that’s OK

Happy to move it back again if you find otherwise

Best wishes