Bug Reports for v

Please report any bugs with this version here…


So far so good.

Initial installation very smooth and quick. Safe list DB creation: scanned drive C and 3 network drives. Total of 124,940 files, 13,891 added to user safe list, time taken for scan 34 minutes 27 seconds. (I would prefer an option not to scan certain network drives - maybe next year?).

Automatic update occurred during safe list DB scan, no freezes or other problems encountered.

Initial drive C scan - 48,629 files scanned in about 15 minutes. Managed to use outlook to send some urgent emails during scan with no system hangs - this seems to be an improvement as I got slight delays if I did this with the previous beta.

Rebooted several times without problems and boot up time so far is about 30 seconds faster than yesterday morning (although I did defragment and clean registry yesterday).

Still no email scanning using outlook and exchange server but I suspect this may be just as well - scanning exchange server files with a file level anti-virus scanner appears to be a bad idea anyway.

The only minor ‘bug’ I have noticed so far is that if I open an application that is in the HIPS allow list there are two pop ups telling me it has been allowed.This can be quite irritating as the second pop up appears just when I am about to click on ‘Run Cleaner’ on CCleaner; surely there should be only one pop up for each allowed application.

Other than this it is looking damn fine so far thank you!

Not sure if this is the right place for this but here goes.

Some results of testing CAVS with the Eicar test files:

First test: I downloaded both of the zip files from the Eicar site. Both downloaded successfully to my computer without any reaction from CAVS.

Second test - right click scan of the zip files. Cavs did not find any virus when the zip files were scanned.

Third test: Open the zip file (i.e. explore it) then double click on the test file. System crashes and must be re-booted.

Fourth test: Extract the zip files. Successful extraction, no reaction from CAVS. Only when the extracted folder is scanned or opened does CAVS quarantine the test file.

Whilst CAVS does eventually pick up the file (thank goodness) I am wondering why scanning the zip file does not pick it up. Surely there is no point in ticking an option box that selects scanning within compressed folders if the AV does not pick up any virus within those compressed folders?


I too got some issues

Comodo Antivirus Email Scanner takes 99% of the CPU while scanning the incoming mails. My mail client is Mozilla Thunderbird.Comodo antivirus makes my machine to take a long time while booting.Other than the above issues Comodo Antivirus works perfectly in my machine.

Does any one facing the issue??? (:AGY)

I’m just installing it at home, where I use TBird. I’ll let you know…


I know I know, this is not the place to post question like this, but I just don’t know where else to post it…

I have been using Avast! Home 4.6, and tested their pro version. I was about to subscribe for that when I came across CPF which I am so impressed (:LOV). So I decided to hold on and see what CAVS would come out with.

Avast has got two features that I liked very much: the script-blocker and web-scanner. What I’d like to know is, is CAVS providing similar functionality?

Meanwhile I have been testing this beta (2.06.12), seems fine and stable to me but, oh… so slow and fat (in memory footprint)! I presume the final version woould not be like that? :THNK

you can put these in the wishlist for CAVS…


this version is better than previous but like them I can’t use Apache Web Server.

If I install CAVS I can’t connect to my localhost server. It seem like if I have on my PC a firewall that block the HTTP port.

But, like all previous versions, if I uninstall CAVS Apache work fine.

This time I have save the log files before uninstall CAVS and I sent it to you.

Thanks, bye.

[attachment deleted by admin]

I think there’s a bug in the file submittion, the progressive bar would go 25%, 12%, 55%, 33% 75%… and eventually >100%… (:NRD)

Performance has become so degraded on my 1.3ghz machine running Windows 2000 that I started leaving Task Manager open to see what is hogging the resources. It’s CavSn.exe, taking up 97-99% of the cpu cycles. That’s not the only problem as I’m still encountering issues like now, when I’m typing along and the screen doesn’t keep up with the keyboard. So I have to stop typing and wait for the rest of the text I’ve typed to show up on the screen. The other culprit seems to be Firefox. Since letting the most recent release install, it takes up as much as 49% of the CPU even when I’m not actively doing anything with it. Between the two of them they had the machine practically stalled. Maybe neither of them plays well with others ? I’ll take this up with Mozilla right now too and will post anything else I learn.

First feedback from the front line of new version testing. :slight_smile:

  1. Installer is nice, fast and works fine on my system, but… i think you can ask user about this little desktop icon. I don’t like this stuff, because i got one tray icon and i can open AV from there, right? Question about it would be nice. I will ad it to wishlist.

  2. I used my standard trojan test - the ‘readme.exe’ file from http://lomalka.ru/ This file is a trojan downloader they use. I download it… scanned with CAV… and nothing. I forced the highest heuristics. Nothing. So I can say I’m just one click from infection :wink: I submitted this file to your lab. Maybe this will help in future.

  3. Application hanging? Example: Submission menu. (for files that look funny for you…) It’s nice, looks fine… but after submission I could not close it! Clicking on cancel didn’t work for me. The ‘X’ icon worked after some time… I think this menu should close by itself after you send desired files to lab, don’t you think? Second thing - CAV detected virus and i could not click in it to mark the file for quarantine… I moved application windows left and then right… and it worked! I could mark my desired file :slight_smile:

  4. The HIPS engine! I was amazed when i saw it :slight_smile: But… I got massive HIPS atack after running my laptop (Lenovo 3000 N100). I can understand this engine don’t know my laptop specific files, but hey - asking me about Firefox and Rundll32 after mounting USB device? :slight_smile: This is new - so i think it will improve :slight_smile: Good going!

  5. System slowdown. My laptop starting time increased (About 50 sec. i think) when i deleted Kaspersky and installed CAV.

  6. System crash! I used Winrar to unrar archive with a virus inside. I opened Winrar, used “Extract to:” and choosed Desktop, HIPS detected unknown WinRAR :wink: and this was all. My system hanged. I could not use menu start, opened application - firefox didn’t respond. My PC didn’t respond to CTRL+ALT+DEL or CTRL+ALT+BACKSPACE. Only hard reset worked :confused:

The infected file I used - ibm00003.exe. Strange thing with it. The infected archive is on my pendrive, when i use CAV to scan the entire drive i get ‘clean’ report. When i scan the selected archive - i got clean report, and only 1 file scanned. Can CAV scan WinRAR archives? After unpacking archive i got no error message, no ‘virus detected’. Nothing! Two files just vanished from my drive to quarantine! Hey! I like to know that i got a virus! When i asked AV to “Deny access to infected objects” it didn’t do anything. I was browsing thru my drive between infected files and i got no virus report.
Right click scan on the drive detected infected files…

  1. Try to do a ‘Right click scan’, then do something else, like internet browsing, and then after virus detection - try to get back to CAV… MASSIVE SLOWDOWN.

  2. On demand scanner. It’s loading slow. Very slow .

  3. Uninstaller. Works fine, but after restart i got some CAV 1.1 install in the boot time, then red icon on my system tray and process cmain.exe and CavAUD.exe in memory… what da? :wink: No option to uninstall from the control panel. I manually deleted the cmain.exe from the registry, and then deleted the folder…

Ok, it’s all for now i think.

The email scanner is able to detect viruses in attachements, but scanning the same file or containing folder using the right click menu still doesn’t work, i.e. the infected file is not detected. Even after saving the file to disk and scanning that (the .zip file instead of the .eml file containing the attachment) it finds nothing.
However while unpacking the .zip file CAVS sounds the alarm bel again, so it seems the right click menu simply isn’t working properly.

It still takes a little while after booting the pc before checking for email works. Probably because some components of CAVS are still loading, but it just takes too long.

Sorry, but we’re still getting multiple instances of CavSubmit running. See attached screenshot. This was without even submitting anything. I have not seen three instances, but I have seen two.

As has been noted, Cavasm.exe seems to be pulling a lot of resources. Opening Firefox was virtually impossible; the on-access pulled 76% of resources; once it slowed down, CyberHawk wanted 36%, and Firefox was trying to pull 50%. Too many things wanting too much. I had to close down CyberHawk and Cavasm.exe so that FF could open. I think it would’ve been okay if Cavasm hadn’t pulled 76% to start with. I have now added FF to the exclusion list, as I have done previously.


[attachment deleted by admin]

After disabling the scanner using the system tray icon (Disable On-Access Scanner) and enabling it again (Enable On-Access Scanner) that information (the re-enabling) is not updated. While hovering the mouse over the icon this pop-up appears:

“Comodo Antivirus On-Access Scanner Disabled”

although it was enabled again.

I’ve made the migration from Windows XP Pro to Windows Vista Business and I understand that it is 99% of my problems because these Betas have worked great until I upgraded. I have several problems now. Everything installs correctly and without error but on restart when the User Definded Safe Database list is supposed to be created I get an error: Error: make UPSDBProc. If I say ok to that the scanner does nothing and I have to press exit. The more important problem to me is that I get Error CAV003 On Access Scanner Failed to Start, and no matter how many times I try to enable it I still get the same error. I dont know how much can be done about this right now but I thought it would be good to let you know.

Thanks guys.

I have the same problem. I have just installed the latest version of CAVS, but, after some reboots, the On Access scanner is always disabled. Impossible to enable it.
Also, if I right-click on a file, and demand to scan it, I have the following message :

Comodo AntiVirus Scanner

Error: Engine Initialization Failed.


I run under Windows Xp SP2, 1024Mo RAM, Celeron 2.84 Ghz.
CPF and CAVS running.

Not really a bug, just an oddity that contribute to connection problems.

CAVSubmit.exe creates an outgoing connection for each individual file in the submit list but does not immediately close the connection after each file submission is complete.

After submitting the first twenty files in the list, I had 21 connections open under the control of CAVSubmit.exe. Once it started uploading a 25MB file, it seemed to catch up, but once it was back onto a series of smaller files, the number of open connections went back up.

Would it be better to perform a close operation immediately after each submission? I’ve peaked so far at 74 connections - other may have “peaked” long before this. :wink:

Ewen :slight_smile:

P.S> The option to backup and restore the safelist in between installs would be great. I reinstall on a regular basis and its a pain in the upload to have upload everything gain.


I use Thunderbird as my email client at home (work is Outlook, where the CAVS email scanner doesn’t work), and I’ve had to turn off the CAVS email scanner entirely, because even when allowed full access in the firewall, it uses all resources trying to scan mail (especially those annoying “stock alert” spams).

However, even with the inbound and outbound scanner disabled, CAVEML still shows up in Task Manager, using 100%, until I end the process.

Apparently, unchecking the scanning option doesn’t actually turn off the scanning…


Shortly after installing the current version, one large file kept failing on submission; it just wouldn’t complete, and it kept saying there was some error on uploading. However, all the others would go just fine. Thus, I removed that one file from the list.

Since that point, whenever there are files to submit, the boxes are checked as normal. Once submitted, however, the file is still showing in the queue, but the box is not checked. I have submitted them multiple times, waiting for the item to disappear from the queue, but they remain, the box unchecked.

The only thing I can do to get them out is to check the box and click remove. The CavSubmit folder stays active though, even with nothing in it. I have to choose to Exit CavSubmit in order for it to close out.


This is to follow up my post here https://forums.comodo.com/index.php/topic,4740.msg35247.html#msg35247, about cavasm.exe usage.

The attached screenshot is while opening XnView (not on the exclusion list). (actually, I took it initially to show that CavEmSrv.exe is running, even though I have all email scanning disabled - what’s up with that?)

I’m trying to get a screenshot of cavasm.exe using its 85% resources while opening Firefox (which is now on the exclusion list). Does the exclusion list for on-access scan not function? It did it a few minutes ago, but I was trying to work with the one I had in the clipboard and couldn’t grab another yet; since then it’s not doing it…

Here’s something I’ve noted. If I open a second instance of Firefox, or even after closing the original instance and opening it again, cavasm.exe does not consume all this CPU resource; it functions more like I would want it to in the first place.


[attachment deleted by admin]