Bug Reports for 2.0.0.1

Hello,

Comodo Antivirus 2.0.0.1 Beta has been replaced by Comodo Antivirus 2.0.0.2 Beta, please upgrade to the latest Beta version of the product.

Please note that CAVS Beta 2.0.0.2 is released for beta testers (only). Those who are interested in testing the latest beta can get more information HERE.

Mine listed here

First I uninstalled Comodo AntiVirus 1.1, rebooted, then proceeded to install Beta 2.0. After installation of Beta 2.0, I rebooted.

Length of time it took to finish running User’s Profiled Safelist DB Maker: 5 minutes and 52 seconds.

After I had clicked the Finish button of the “User’s Profiled Safelist DB Maker” my system remained completely unresponsive for approx 1.5 to 2 minutes: it appeared frozen, not accepting any mouse or keyboard interaction; I was just about to reboot when my system came back to life.

My system remains noticeably less responsive than before the installation of Beta 2.0. Tried rebooting again. And upon entering the Windows Desktop the “User’s Profiled Safelist DB Maker” automatically ran again, this time taking 5 minutes and 24 seconds. Rebooted a third time. Once more upon entering the Windows Desktop the “User’s Profiled Safelist DB Maker” automatically ran again, this time taking 5 minutes.

Does the “User’s Profiled Safelist DB Maker” automatically run every time Windows is started?

Due to HIPS activity (?) there are recurring lags in system/application responsiveness, one example such as the opening of programs.

System/applications also less quick to respond when running a Full Scan.

Windows Security Center still does not recognize Comodo AntiVirus beta 2.0. Message in the Windows Security center says: “Virus Protection: Not Found.”

Rightclick Scan of a file…

1.) Right Mouse Button click on a file
2.) On the context menu, click on “Scan with Comodo AntiVirus”
3.) When finished scanning, a dialogue box pops up saying, “Comodo AntiVirus Scan is completed.” Click on the OK button and the dialogue box closes.
4.) Now the Rightclick Scan Summary window says “Scan is completed. No virus found.” Click on the Close button of Scan Summary window.
5.) Another dialogue box pops up saying, “Do you want to close the window?” Click on the Yes button and the Scan Summary window closes.

Overkill / Annoyance: perhaps we can get rid of the above step number 5 altogether.

Typos / Spelling Errors / Suggestions / Questions…

1.) Under Scan Schedule / New / Schedule Task / Scan Schedule / Weekly / Schedule task Weekly / Week Day, Saturday is still spelled as “Satuarday.”

2.) Under Settings | Email Scan | General (and Advanced): rather than use the word “mails” would not using (consistently throughout) the word “mail” - or perhaps the word “e-mail” - be more pertinent seeing that either word, mail or e-mail, in and of itself already refers to one or more mail/e-mail?

3.) Under HIPS Application Control | General: next to the check box of where it says, “Enable automatic submission of files those are not found safe” would it not read more clearly if worded, “Enable automatic submission of those files not found safe.”?

4.) Under HIPS Application Control | General | Security Level: under the Medium description, is it necessary to embolden, so as to stand out, the words “Most common applications”? under the Low description, is it necessary to embolden “.exe”? (Under the High description, none of the extensions are emboldened.) At the end of the sentence there is no period after the word “execution” whereas there are periods at the end of other sentences. under the High description, there is quite a blank space between the words “applications” and “like”; no space between sentences (see words “execution” and “Only”); is it necessary to embolden the words “known safe application”? Lastly, where it reads, “Only known safe application will be allow to execute irrespective of allow / block list.” - the word “application” ought to be “applications” and the word “allow” should be “allowed”

That’s it for now…

Laurence

===
This system is running Windows XP Home SP2, all Windows Updates applied, a Pentium IV 3.4 GHz with 2 MB L2 Cache, 2 gigabytes of RAM, and a SATA II drive.

Mine are here.

I’m not sure if this is a bug, but I’ll attempt to explain it using what I have seen… hope it helps

After uninstalling beta 1, and installing this one I reboot like it says. Then it attempts to catalogue my safe files or something of the sort. I just let it do what it’s supposed to do. After about 45 minutes of waiting for some progress I see nothing so I decide to cancel it. During this 45 minutes I was trying to access the CAVS control panel, or whatever you’d like to call it. I tried clicking on the quarantine button, open CAVS, all this other stuff that comes from the icon in the task bar (when I right click it). I even tried using the desktop icon. Nothing happens.

It’s at this point I went into task manager. In there, under processes, it reveals CAVS is working, but it’s not using any (according to the “CPU” column under processes which reads “0”.) None of the CAVS many processes were using anything. I found that weird, because even something like task manager was using a few “CPU’s”?

I also tried to access other programs besides CAV like firefox, MS Word, CCleaner, Spybot, etc, just to see if they would work. Nothing did. But the computer wasn’t locked up or frozen. In fact, where it usually should say 100% if locked up it said something like 10% if I recall, next to nothing. I tried uninstalling CAV using the control panel, figuring that was my last option but it wouldn’t work. I clicked the button and it just sat there as if nothing happened.

I ended up having to reboot in safe mode to get CAV out. I’m going to attempt to reinstall tomorrow when I have more time.

I hope this helped somewhat, apologize if it wasn’t a real bug and just my lack of knowledge, but I can’t wait to get this running some more.

GOOD LUCK CAV TECH TEAM!!!

System Windows XP Pro SP2 fully patched and updated system 1.8mhz with 512mb ram
New Beta 2 installed after 5 reboots to get 1.1 cleaned from system.
Everything running :slight_smile:
After 30 minutes of the full scan I get an error message, see attached file.
Rebooted then after 20 minutes I get the same message.
Other than this crash, which just shuts down the a/v scan everything else seems OK.
After 3rd reboot the installer is back trying to put version 1.1 beta on my system again ( I thought it was gone)
Comments welcome!
Keep up the good work guys!

3rd time is the charm (starting the scan, fingers crossed)

[attachment deleted by admin]

I installed CAVS 2 on my computer but when I rebooted I could not connect to the internet. I uninstalled CAVS 2 and had to do a system restore to get back online. I dont know if it was something i did or A bug in CAVS 2.

Ok, I’ve beta tested CPF and other programs before so I thought I would give this a shot. Here’s how my results went down:

I’m running a 2.08 GHz AMD Athlon XP Processor with Windows XP Home SP2 fully patched.

Upon restarting my computer, both the Safelist Scanner popped up as I expected (from reading here). Along with that, an activation menu popped up as well. I clicked on the “Get Free License” or whatever and my system became unresponsive. I could not click in the traybar (start menu) or anything. I could not run new programs so I rebooted.

Second reboot and same thing occurs. I restarted another time or two (after a while the activation popup went away) with the results of whenever I moved my mouse down in the taskbar the mouse would change to the hourglass cursor. I could not click on the start menu, quick launch, or systray. Starting new programs from my desktop would further stop my computer.

I had to reboot into Safe Mode and uninstall CAV 2.0 Beta so now I’m back using my old AV program for now.

Anyway, thanks for the hard work you put into this program even though I haven’t been able to use it. I’m sure you guys will do a great job in making this program the most stable it can be. ;D

Thanks for everything,

Drew :slight_smile:

Please send the Troubleshoot Logs to analyse this issue. You can collect the logs from CAVS settings. Go to Settings->Reports. Click “Save log” will saves logs. If it is failed, copy this folder(%Documents and Settings%\All Users\Application Data\comodo\Comodo AntiVirus\TroubleShootLog) and send to us. This logs will help to us for further analysis.

The system became almost unusable, because some program didn’t run properly and after a few minutes Windows popped up a message about a missing dll (don’t remember the name). I decided to reboot to see if that would do any good, but restarting was not possible anymore because of the old missing hal.dll problem. This also happened with the previous beta. I’ll wait until this problem has been fixed before installing CAV again.

Hi dsekirka,

Please send the Troubleshoot Logs to us for reproduce this issue.

regards
Gopal

2nd reboot this morning.
Blue screen, your computer has been shut down…blah…blah
Stop 0x0000007B (0xF8951528,0xC000000E,0x00000000,0x00000000)
Tried booting into safe mode 2 times, same message.
System booted up using last know good configuration.

On startup I noticed the 1.1 installer still trying to do its thing for 1 minute.
It stops right when I get the pop up that says Comodo A/V on-access scanner enabled.

Something isn’t playing nice on the box. Looks like the culprit is with the 1.1 installer renmants.

Keep up the good work guys,

Anything I can add to help out give a shout.

Dr Pete

After much pain to get CAVS 2 to accept that CAVS 1.1 was uninstalled (still getting a 1.1 installer window briefly on startup, like DrPete) (my process is in here, I have it up and running (doing a complete scan now; using some resources, but I can still perform basic functions, email, etc).

Two minor issues:

  1. On installation, I chose not to do the SafeList creation; CAVS did it anyway.
  2. After completing the SafeList, it still didn’t recognize Outlook 2003, and alerted me when I opened it (it’s the only program it’s done that to so far; after completing the list).

A suggestion, for the future: If, when the stable version is released, an uninstall of Beta 2 is required, please include an automatic uninstaller w/the stable version that will automatically uninstall the beta version in a way that the stable version accepts as being uninstalled (if you read my process linked above, you’ll understand why I say that).

Keep up the good work! I will post more as I get more. :slight_smile:

LM

Just wanted to thank you all for helping us with our Beta product.

The work you are doing will benefit millions of users, who can’t afford to buy, or not prepared to pay for this type of security.

Please keep it coming. we need your help.

Thank you, thank you, thank you!

Melih

Well, you see… I couldn’t even start up CAV before my system stop responding so I couldn’t save the log. I went to that folder there and it was empty. I’m not running with CAV installed on my system. I can try again later and see if I get the same results I mentioned before.

Thanks for everything,

Drew

Drew, I may have had a similar problem on my first install of CAVS 2 Beta, and the problem was explorer.exe - my perception is that somehow it got thrashed by some interaction with the Beta (Betas are fighting fish, after all) :). At any rate, I couldn’t do anything w/CAVS, or ANYTHING on my system. I rebooted in safe mode and Restored. I probably should have done some diagnostics at that point, but I just thought I’d go thru the process again and see if it worked (then I ran into trouble…). Don’t know if a hijack this log would show it, but maybe that would help (since there’s no CAVS reports to be had…). Or one of the other system-monitoring tools, maybe…

LM

The program still needs a lot of work. For some reason it deletes or causes the deletion of lots of system dlls, including the infamous hal.dll. Apart from that file it deleted at least the following files within a short time after installation:
wmvcore.dll
aclui.dll
crt.dll
oledlg.dll
olepro32.dll
crtdll.dll
I replaced those, but they might be deleted again at some point. Lets wait and see…

I don’t know if this is the only reason, but many programs don’t work normally (very slow, if they work at all.
.bat files won’t run at all. Windows reports it can’t find them, even after double clicking on them directly…
Verdict: CAVS is unusable at the moment.

EDIT:
In spite of the fact that I replaced the missing hal.dll manually, the system wouldn’t reboot anymore. This was the error message:

Windows could not start because of an error in the software.
Please report this problem as:
load needs DLLs for kernel.

I’ll leave the testing to others for now.

Anyone having problems with sending their “Safelist” into the main server?

It was taking a long time, and using a fair amount of resources (but not to the point of hanging); I wanted to monitor it but had to go, so I finally stopped it and left it for later. That was all I experienced. It had 26 files to send. When I stopped it, there were 10 left. It had taken about 10 minutes to get to that point.

LM

G’day,

Second attempt at installing CAVS2 was successfull. Duno what was differentother than my patience level. lol

When sending the safelist, error dialogue appeared stating “Disk full when trying to write submit file”. Local drive had 37.1 GB free out of 80GB.

Also, there is no clear indicator of hwether the files in the safelist are still to be transmitted, are in the process of being transmitted or have already been trasmitted. If they have been transmitted, do the files remain in the list?

cheers,
ewen :slight_smile: