BUG REPORT: pidc.txt Error box on startup; keyboard disabled if CIS disabled

Win 10 x64 Pro. Was using CIS 8.x. Since installing version 10 last night, I’m getting the attached error box on every computer startup (several). Never saw it before that. I’m guessing it’s Comodo related, one way or another.

A. THE BUG/ISSUE

a) On computer startup, Comodo CIS 10.x (free) returns Error box with “can’t find pidc.txt”

b) with CIS completely disabled, at startup there is no pidc.txt error message but my keyboard is disabled

c) after complete uninstall with Revo Uninstaller Pro (advanced scan) and clean reinstall, a) and b) are still happening

d) Since the resintall, MS Office Home & Student 2010 programs won’t open, returns “There was a problem sending the command to the program” error message, even with the Office programs excluded. Disable CIS, reboot and the programs open. (After the first install, I saw an MBAM warning when opening a clean Excel file, but just excluded it and everything seemed ok.)

Can you reproduce the problem & if so how reliably?:
YES, every time (five now)
And someone else reports it too:
http://www.jordanhardware.com/threads/getting-pidc-txt-error-message-windows-10.366050/#post-367770

If you can, exact steps to reproduce. If not, exactly what you did & what
happened
:
1: update to CIS 10 from 8.4 (latest); i.e., it has happened with every computer startup since update from 8.4 to 10.0

2: after disabling all Comodo entries in Autoruns, there is no pidc.txt error box - and my Keyboard is disabled(!). Tested twice, with CIS reenabled in between tests. And then a third time after uninstall/reinstall.

3:
One or two sentences explaining what actually happened:

Initially, the Error box appeared immediately after upgrading from CIS 8.4 to CIS 10.x. Also had uninstalled Geek Buddy and Dragon browser.

On the clean reinstall, I unchecked Geek Buddy and Dragon under Components. However, Internet Security Essential does not show in autoruns or installed programs. Is that because I unchecked Secure Shopping?

One or two sentences explaining what you expected to happen:

No error box, keyboard independent of Comodo, Office programs run

If a software compatibility problem have you tried the advice to make programs
work with CIS?
:
n/a

Any software except CIS/OS involved? If so ­ name, & exact version:
Yes. MS Office Home & Student 2010 (up to date)

Any other information, eg your guess at the cause, how you tried to fix it etc:

I tried creating pidc.txt file in the same Temp folder as pid.txt, but it’s lost on reboot.

B. YOUR SETUP

Exact CIS version & configuration:
10.0.0.6086, DB 26331
default settings
Secure Shopping off

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
default
AV = Stateful
AutoSandbox = enabled
HIPS disabled
Viruscope = enabled
Website Filtering = enabled
Firewall = safe mode

Have you made any other changes to the default config? (egs here.):
Secure Shopping disabled

Have you updated (without uninstall) from CIS 5, 6 or 7?:
from 8.4 (latest version 8)

if so, have you tried a a a clean reinstall ­ if not please do?:
Yes

Have you imported a config from a previous version of CIS:
No

if so, have you tried a standard config ­ if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:

Win 10 Pro x64, UAC off, standard Windows account for 10, desktop computer

Other security/s’box software a) currently installed b) installed since OS, including
initial trial security software included with system
:

a=MBAM Premium b=Spyware Blaster c= Secunia PSI
d= After writing bug report, I discovered Windows Defender was enabled (not by me), but is now off w/o changing problems reported here

Screenshots and Cis Report attached. Don’t see Watch Activity in this version.

I do not think such file is used by CIS. After a quick search, it seems to be related to Windows.

The pid.txt file is there in the Windows\temp folder. Not sure what this pidc.txt file is, and it’s not mentioned as such on the TechNet page you linked. In addition, a search on the name doesn’t turn up anything, but someone else is getting it too today: http://www.jordanhardware.com/threads/getting-pidc-txt-error-message-windows-10.366050/. Don’t know yet if they updated to Comodo 10.

I did create a pidc.txt file, blank and then with the same and different text as pic.txt, but it disappears on startup and the Error box appears.

It’s Comodo - and with an additional serious odd problem.

After disabling all Comodo entries in Autoruns - Startup wasn’t enough - two things happened in two tests with Comodo reenabled in-between:

  • no pidc.txt error message
  • no keyboard

How would Comodo be tied to the keyboard?

Mod edit: copied bug report to first post. -futuretech

Can you try a clean uninstall and then re-install of CIS to see if you still experience the issue? Disabling autorun entries for comodo shouldn’t affect the keyboard, you sure you didn’t disable the autorun for something that works with your keyboard?

Well, pidc.txt shouldn’t have anything to do with Comodo either, so it was said earlier. And someone else reported the same problem last night, so it seems something is happening, whether general or specific to certain setups. In any case, I used a Comodo search (F3) through autoruns the first time, and then when the keyboard was disabled, slowly went down the list to reenable or disable again. It’s not hard, as all the Comodo Publisher entries are in caps.

I’m running an image backup right now, then will do an uninstall/reinstall using Revo Pro and report back.

Did complete uninstall with Revo Uninstaller Pro (advanced scan) and clean reinstall and got the same results:

  • pidc.txt error box

  • no pidc.txt error after Comodo completely disabled (used filter), but keyboard disabled (not recognized) on reboot.

  • New?: Since reinstall, ISE doesn’t show in installed programs or autoruns. After the install, I unchecked Secure Shopping in Settings, if that’s the reason why.

I’ve updated the Bug Report to reflect the reinstall results.

UPDATE: Office Home & Student 2010 programs also don’t work since resinstall. Strangely, got a warning about an Excel file from MBAM soon after the first CIS install, but just created an exclusion in MBAM and that seemed to settle it.

Make sure that nothing is virtualized. Keyboard issue makes me suspect that’s the problem.

What do you mean by virtualized? Had never been an issue with previous version, 8.4.

auto-sandboxed.

Compared to version 8, there were many changes. Sandboxed applications are unable to tamper with your keyboard (eg registering hotkeys on “real” system) with version 10.

OK, but when the keyboard never comes on with CIS disabled, and nothing indicates Office is sandboxed when CIS is enabled - and sandboxing is typically announced - where would does one look?

Did you check Logs and Blocked Applications?

I checked blocked applications a number of times because 10 was starting anew. Office was not on there. I don’t recall looking at the logs. And, of course, there was the issue of pidc.txt error box.

By the way, checked your diagnostics report and there’s no problem with CIS. Strange.

Agreed. One thing I didn’t try was install from safe mode. Just yesterday I had to do that with MBAM Premium, when an update install returned an error that prevented completion. Made me think of some kind of malware, but scans, including with ESET Online, yielded nothing but a couple of PUPs.

BTW watch activity is located under tasks>sandbox taks. Or you can open either the view connections task or active processes task and click the more button at the bottom which will then prompt you to download and install killswitch/CCE. Once killswitch is installed and running goto file save view and attach the file here. Also do you have any special software that is used for your keyboard?

No, nothing special. This is a good ol’ IBM model M from the late '80s.

Try the following :

  1. Go to Advanced Settings > HIPS
  2. Disable “Detect shellcode injections”
  3. Disable “embedded code detection”
  4. Restart system

Any effect?

If issue persists, try the following :
0. After mentioned error message appears

  1. Get Process Explorer Process Explorer - Sysinternals | Microsoft Learn
  2. Find->Find Handle or DLL
  3. Type filename from error message
  4. Make a screenshot / Anything interesting?