BUG - printing webpages


it seems there is a bug. If I print a page (both to a pdf printer or a phisical printer) you get the right toolbar (the one where you can drag to wikipedia, youtube etc) superimposted on the page about 2/3 of the way on the right. This happens when the bar is not visually displayed on the webpage when you click the print butto (or press ctrl+p).

Any solutions? This means I cannot use the browser for work as I frequently print to pdf the pages.


Comodo Dragon Version (Stable/Beta) e.g. Dragon (Beta); e.g. Dragon (Stable)
31.0 stable

Plugins/Themes installed in Comodo Dragon
ghostery, roboform, adblock, https, duckduckgo, WOT

Windows version (w/ 32 or 64-bit) e.g: Windows 7 Ultimate (64-bit); Windows XP SP 3 (32-bit)
Windows 8.1 pro 64 bit

System Drive where Windows is installed (e.g. C:, “C” Drive )

User privileges (administrator, limited user, guest, etc.)

Example, see attached PDF

[attachment deleted by admin]

Having same problem…attached is PDF of an email I tried to print out…

[attachment deleted by admin]

Same issue for me too - back to Firefox I suppose

I think I found the answer.
Go to your extensions page, and disable: Comodo Drag&Drop Service.

It will stop the stupid sidebars from working, and showing up in PDF’s that you print. It worked for me, I hope it works for you.

If you need to see what I am talking about, I have attached a screenshot highlighting the feature or you can reply if you have a question.


[attachment deleted by admin]

Please watch your words… There is a good work a toil on this extension. I think devs workin’ on this issue and it will be fixed in the next releases

Kind Regards…

My apologies to the devs, it truly is a neat extension for Dragon that will have a lot of usefulness when it is fully operational.

However, I had no idea where the sidebars came from and how to fix the bug, aside from a very quick explanation when it first came to the browser. “drag anything the right or left to search or share” was the notification, if I recall correctly.

There was no documentation about this new feature, and if I hadn’t found the workaround (by disabling it) I wouldn’t be able to print PDF’s.

Calling it ‘stupid’ was too strong of a word for this potentially useful feature, but it wasn’t a very good decision to roll out this new extension across-the-board without letting the users know more about the new feature and that there might be issues associated with it, and that it is a Dragon-exclusive feature. I spent a lot of time searching google-related news to find out where this came from, if you will recall when Google rolled out the revised tab page that everyone had to disable. If there was a tab opened by the extension displaying information about this new extension the first time I opened my browser when the extension was first installed, that would probably help most users determine the cause this or another extension-related bug. The page could even be opened again from a link provided in the extension’s description on the installed extensions page.


I understand your problem but it is a new feature for us and for our brorsers CID and CD. (version 1 )
Yes there is bug when printing PDF, I said I hope it will be fixed soon. Are you printing the PDF everytime when using your browser 88) Disabling the extension when printing looks solve the problem.

This extension is very easy to understand and use. I think no need to explain you know better than me :smiley:

example : Drag links and drop to the left for sharing, drag words and drop to right for translete, web search, wikipedia etc.
thats it , this is working now for me perfectly. :-TU

Thank you jimmyb254…

I am back to printing normally again…I won’t have to go to another browser…

Just an FYI for the developers…I was having the problem on BOTH printing to PDF’s and on different printers in different offices…

Thank you again…

I agree with this solution… I had the same issue and this one worked for me as well… thx to jimmy


the new feature is neat, but its utility is very much reduced if you suddenly cannot print webpages any more. The problem happens to regular prints as well, not only when printing to pdf. I appreciate that many people never print webpages, but many others do and this is a big problem for them. I thank you for your fix, I’ll have to disable the feature until it is fixed.

Having the same issue ???