Bug or virus?


something strange happens with my CIS
There is a file among the unrecognized files, it is an exe. It has got the name of a pdf which I have downloaded, which I do not remember if it was on a zip or directly as pdf, but I am sure it was not as exe (I would have never opened it).
I have selected it and submitted it. Then I have moved it to blocked files. Then I have deleted it.
I press ok and the windows closes and I can see the main CIS window, and there still is that “1” near the unrecognized files, so I click there and I see that the file is still on the list.
I purge the list, and it is purged, the entry is considered NOT valid, the file is not found on the system. And if I click “lookup” the result is “failed”, and when I click on its clickable name on this popup which opens when I lookup, I get the error “windows cannot find the file”.
I go to the location and I search with the search function of windows, and it is not found.
I run Comodo Antivirus and do a deep scan, and the same with Malwarbytes (rootkit option active), and nothing is found.
But whatever I do, remove, move, delete, purge…, the file is ALWAYS again in that list of unrecognized files.

Is it a bug? Is there a way to “reset” the list, to find the file corresponding on that list, delete it, let Comodo create a new one?

Or can it really be a virus?

The Unrecognised Files list is best seen as log rather than a task manager like program. It logs all unrecognised files CIS has seen.

Hello, yes, i knew that, but, there is a purge function to eliminate from the list the invalid voices, a remove function to remove even valid voices, a delete function for (as far as understood) delete a file from the system.
And they work as expected with ALL other files.
Not with this. I purge and it is purged as invalid, which means that Comodo thinks it does not exist anymore.
But as soon as i reopen the unrecognized files window, that exe is there again.
I remove it, same story.
I delete it, and story.
I look for it in the folder (hidden files shown) and it’s not there.
So, don’t tell me it’s normal.

what is the name of the file? can you show us a screenshot of the file

You mean a screenshot of the unrecognized files window?

yes with the file you are mentioning

Here we go.
I hope the upload works, I have never done it before.

Thanks :slight_smile:

[attachment deleted by admin]

Are those characters in the file name Cyrillic?

There is currently a bug that doesnt allow the user to move files from the unrecognized files list if they contain Cyrillic characters.


Hi, those characters were not in the original file. But there were things like ü and ä.
It’s German.

maybe you are experiencing the same bug but with a different language

Ok, but, why is the file still visible in that list even if it is no more present in my PC?
The guy in that thread does not speak of deleting the file from the system…
As far as I can tell, I have deleted it.
If I go in that location, it is not there. If I search it with the search function, it is not there.

Should I just reinstall Comodo?

it might be part of the bug. we would have to ask that user to try deleting the file to see if its the same bug.

Sorry for the very late reply, I was with exams and then moving home and then no internet.
I just wanted to say, having few time and wanting to try first the easy way I have just reinstalled Comodo.
Problem solved.

Now I have another problem so I am going to post another thread :slight_smile: