Bug in updates of CFP_Setup_3.0.23.364_XP_Vista_x32 and CFP_Setup_3.0.24.368_XP_

I updated version to The update succeeded and the firewall reported working correctly and showed the new version in the about entry, but a check for updates reported that they were still new updates (the same
I tried applying the update several times with same results.
It already happened to me on a previous version and I solved the problem then by uninstalling and fully installing the firewall, so I tried this with the version but it didn’t help.
The updater wants all the time to download new updates.
Any ideas?
Maybe some registry entry is not updated?
I am running on Vista Ultimate SP1 32 bits (as administrator).

– George

I updated to the new version CFP_Setup_3.0.24.368_XP_Vista_x32 and it did not solve the problem.

– George

The problem has to do with the query about the status of the firewall not succeeding with the UAC on.
I disabled UAC and rebooted, thinking the update might succeed with UAC on - instead Comodo reported that there were no new updates.
I turned UAC back on, rebooted and Comodo reported that there was a new update.
I closed Comodo, ran cfupdate as administrator - it told me there were no updates.
I restarted Comodo and it reported that there were updates.
Hover, now it does not report the version number - the field is empty.
I reinstalled it with UAC off and it corrected the version display and said that there were no updates.
I turned UAC back on, and I am at the same stage as at the beginning: the version displays correctly, but the firewall claims that there is an update.
It may be reading the current version for update information from another file than cfpver.dat in the Programs folder (that has the correct information), but if this is the case, I could not find it.

So this is looks like something for the Comodo team to fix.
Version 349 did not have this problem (it did have a similar looking one, but now it seems that it was a different one, see my first post).

– George

See https://forums.comodo.com/help_for_v3/tutorial_on_how_to_make_cfp3_work_nicely_with_vista_and_uac-t20463.0.html for a temporary solution.

– MODERATOR: Please remove this thread, since there is another one and a temporary solution.